Can't Quit Preview (It's Locked Up)

Discussion in 'Mac OS X System & Mac Software' started by Greg_Reez, Sep 16, 2009.

  1. Greg_Reez

    uix_expand uix_collapse

    Jun 30, 2008
    Likes Received:
    I rarely use preview for anything but this time I double clicked a file from a CD that just happened to be a 500mb tif. Preview began launching, but now it is not responding, like its basically frozen. I right clicked the icon in the dock to force quit, nothing. I opened the Force Quit Applications window, highlighted Preview (which is red and says not responding) clicked force quit, nothing.

    So I decided to eject the CD which I can't because it says the disk is in use. I tried to shut my computer down which I also can't, because it says that Preview isn't shutting down.

    Please help, how can I quit the program or shut down my system so I can take the CD out?

    * Tried quitting the process via activity monitor... nothing.
  2. ElDiabloConCaca

    uix_expand uix_collapse
    U.S.D.A. Prime

    Aug 22, 2001
    Likes Received:
    You can "kill it with impunity" via the Terminal.

    Open Terminal, then use either 'ps' or 'top' to get the PID ("Process ID") of

    Then, in Terminal, type "sudo kill -9 PID" where PID is the PID of Type in your admin password, and it should kill it.

Share This Page