CD's Without An Image/How To Crash OS X


So a PC friend of mine lends me a data CD that contains two movie files. This isn't the first time he's lent me data CD's like this, and I've never had any problems with them. I take the CD home, pop it into my CD drive (slot-loading Matshita CR-RW CW-7121 built into my 500 MHz PowerPC iMac from 2001 running 10.2.8, and please don't remind me of how I am in desperate need of upgrading). I hear the sound of the CD being read. After that, nothing happens. And by "nothing," I mean "nothing." More specifically, the CD icon that is supposed to appear doesn't appear.

Now, I can open up Toast and find out that the computer does recognize the fact that there is a CD in it, but it just can't read any of the data on it because the disc itself has no image. What's even weirder is that I can actually get Toast to creat a .toast file for it, but it can't mount. In fact, attempting to mount it in Disk Copy causes the system to crash.

That's right, OS X has crashed on me, and it's because of this. The desktop goes dark, and there's a box in the middle of the screen telling me in 5 different languages that I need to restart my computer by holding the power button (though I generally opt for the reset button on the side), while I am unable to move my mouse or do anything at all, period.

The data on the CD can be accessed on a PC, but I want to know how I can access the data using my Mac. This has happened to me once in the past, but the problem was never solved.

Is there anyone who can help me?
It sounds like the CD that was burned on Windows wasn't "closed" -- meaning, Windows lets you burn data to the CD, but leave the CD "open" so you can burn more data later. Mac OS X doesn't like this very much.

You may want to ask your friend to burn the CD and "close" or "finalize" the CD. This may help. It would also help if the CD was in ISO9660 format, since that's a good cross-platform compatible format.
Thing is, that isn't an option at the moment. I don't mean to sound rude, or anything, but that's pretty much the long and the short of it.
Well, if the Mac won't read it, the Mac won't read it... I don't think there's much you can do other than a) get your friend to re-burn the CD, or b) try a different computer.

Have you tried using the Terminal to see if you can get data off that way?
I guess if no volume's mounted, no volume's mounted. The Terminal doesn't change that.
But what you _could_ try is to boot in OS 9 if you still have that on the iMac and see if that mounts the CD. (At least, OS 9 uses different drivers for the drive...) From there you could copy the files and then reboot into OS X.