Change Icloud Account In System Preferences

John Varela

Registered
I got myself thoroughly entangled in multiple iCloud accounts and need help getting out. Here is the problem:

When I open System Preferences => iCloud a dropdown says "Back to My Mack can't start because of a problem with your account." Click OK and this pane vanishes. However, all the listed services are grayed out and so is the Manage link. There are two choices: Sign Out, and Enter Password.

At the left, there is displayed an iCloud ID for which I have the password to enter the account on iCloud.com, but that password is not recognized by System Preferences. The 1Password entry for Apple ID lists previously used passwords, but none work with System Preferences. It responds (in red letters) Your Apple ID or password is incorrect. The one that I just now tried is the one that works with iCloud but System Preferences won't accept it.

My question is: how do I remove and reinstall or replace the iCloud account and password stored in System Preferences?
 

John Varela

Registered
Thanks for trying but I am already very familiar with the change-your-password pages. I can sign into iCloud.com and get into the management page. The problem is I can't open the System Preferences => iCloud page on my iMac to set up Services. All the Services are grayed out and System Preferences won't accept what is, as stated above, a known valid password. Just this evening I tested the problem ID with 8 previously used passwords going back to 2015 (they are preserved in 1Password) and eight of them were rejected and two hung System Preferences so it had to be Force Quit. Sometimes the same password will cause a hang and sometimes it will just be rejected.

I keep getting alerts, some of them screwy, such as one this evening that says "This Mac can't connect to iCloud because of a problem with 'xxxxx@gmail.com'." That gmail address is my iCloud rescue address set up in the Manage ID web page at iCloud.com and I have no idea how the iMac even knows it exists.

I have been on the phone with three different techs at Apple ID and this was supposedly elevated to Engineering yesterday for resolution within 24 hours but it's now been 32 hours and nothing done. Anyway, they are going at it from the wrong end; I'm convinced the problem is in the iMac but they are supposed to be digging into iCloud files to untangle whatever is wrong.

Surely I'm not the first person who has needed to change his primary iCloud ID.

I came here because the last supervisor I talked to at Apple works four days and won't be back in the office until Tuesday. I'm hoping someone on this Forum can help me.
 

DeltaMac

Tech
I suppose you have verified it's not a user issue on your Mac?
Have you tried while logged in to iCloud using a different user account on your Mac?
Have you tried getting in to your iCloud settings from a different Mac?
(I have 3 different Macs, one several miles from here, all using the same AppleID account. Maybe you don't use the same AppleID on multiple Macs. That may be a better choice for me, too :D )

If your iCloud reports that there is a problem with the rescue address, do you have a problem with that address? Reason I ask, is that my primary AppleID account address is totally unused, also a gmail account, but not ever used for mail. I have not ever tried that account to see if it still is a working email account. I assume that it is good, because I never get login errors from AppleID - which was the reason I created that gmail account in the first place, and the only reason I have a gmail account.

I think the usual "fix" when you can't get into your main settings, or can't successfully reset password locally, is for AppleID to do an account reset from their end. This would normally take several days to complete, going by the last (and only) time that I had to do that, too, about six months ago.
 

Cheryl

Rosie Moderator
Staff member
Mod
Your iMac knows about your rescue email, because iCloud web shares information connected to your account with your iMac.

How about ....Cleaning up 1Password. Remove those old iCloud passwords - the ones you know are no longer used and don’t work.

Next - System Preferences is doing something funky, so it is time to give it a freshening up.

Go to your user’s home folder>Library>Caches> com.apple.systempreferences folder. You should see a file named Cache.db (or more than one). Delete that file (s). You won’t hurt anything as a cache is just saved activity similar to your browser’s cache.

Do you remember what those Apple techs had you do on your computer? Trash any preference files?
 

John Varela

Registered
It's all solved. This is for the record in case someone else gets into a similar tangle.

Three things were needed: Delete the existing iCloud accounts from my computer, remove the old Primary account from the Apple servers, and then name one of the formerly secondary accounts as the primary.

As stated above, the inaccessible iCloud account was to be removed. Before the Apple guys got around to doing that, however, I went to ~/Library/Application Support/iCloud, and found the Accounts folder. I deleted that folder and restarted the computer. That cleared up access to System Preferences > iCloud, which was no longer grayed out. I was able to get into System Preferences > Internet Accounts and set things up. I tested email in and out, and calendar sharing with iPad and MacBook Pro, and all was working. However, I couldn't log into System Preferences > iCloud to manage the iCloud drive. That was of no immediate concern because I don't use the iCloud drive.

I phoned the number that Apple tech #3 (she doesn't work weekends) had given me and left a message to her not to let them kill the Primary iCloud account because I had everything working.

Too late.

The Primary iCloud Account was deleted, leaving it still the Primary account as far as my Mac was concerned. A fourth Apple tech at a different phone number that #3 had left in case of need, 800-275-2273, brought everything to a happy conclusion. I didn't take notes, but from System Preferences > iCloud she somehow got me into a pane to sign up for a new Primary account ID, something I had never seen before in a lot of testing. I suspect it was the removal of the old Primary account from the server that made this possible. I had to inactivate one of my two surviving iCloud accounts in System Preferences > Internet Accounts, then return to System Preferences > iCloud and sign in with that ID. Presto!

Everything is, as far as I can tell, now working and set up as I wanted it.

Thank you to those who tried to help.
 
Top