click drag stopped working

pedz

Registered
I have a Magic Track Pad. On both of them, the tap drag to create a selection stopped working. The "Tap to click" is working and the click and drag to select is working but not the tap and drag to select.

Any ideas of what happened?

This started a few days ago and continues today. I've rebooted. Right now, I'm repairing permissions on the hard drive and will reboot again but I doubt that will fix it.

Thank you for your help
Perry
 

DeltaMac

Tech
Looks like your description is not the same as your thread title.
Does that tap and drag function work when you are logged in to a different user?
 

pedz

Registered
Yes to both :) click drag is working. tap drag is not working. Just tap is working.

With a different user, it is working fine. Both users are non-admin.

I have Better Touch Tool but even with it deleted, I still have the same issue.

As expected, Fixing Disk Permissions and rebooting did not help.

The weirdness started a couple days ago. At that point, even tap did not work. I "fixed" it by unchecking the "Tap to click" and checking it again.

Thanks for your help.
Perry
 

DeltaMac

Tech
Try removing the .plist file that provides the settings for your trackpad.
It's probably in ~/Library/Preferences, then the file named com.apple.systempreferences.plist
You can easily find out which .plist, by changing some other settings in your trackpad settings in system preferences. Sort the files in your user/Library/Preferences folder by date modified, and the newest files should be the likely ones to delete.
another file in that folder that MIGHT interfere is com.apple.BezelServices.plist
You should have no problem removing that file, too.
Log out, then log back in to your usual user. Change your settings to those that you prefer.
 

pedz

Registered
That didn't work. Something is really odd. I would expect the settings to go back to their defaults but they are not.

I tried doing it from another user thinking that the Finder (or something) was writing out their old copy but that still didn't work

I even tried rebooting, log in a the admin, delete the files, log out and then back in as the affected user and that still didn't work.

I removed Better Touch Tool as well.

I did ls -ltr to sort by time and removed things using the shell.

The one trick I thought about was copy the good users preferences over to the bad user. I haven't tried that yet.

The files changing with I muck with the track pad settings are:

com.apple.driver.AppleBluetoothMultitouch.trackpad.plist
com.apple.systempreferences.plist
ByHost/.GlobalPreferences.94C9A175-2B4E-56A3-896F-D8F1F0380144.plist
ByHost/com.apple.loginwindow.94C9A175-2B4E-56A3-896F-D8F1F0380144.plist

I've not mucked in the ByHost files but I have tried deleting these files:

com.apple.BezelServices.plist
com.apple.driver.AppleBluetoothMultitouch.trackpad.plist
com.apple.loginwindow.plist
com.apple.systempreferences.plist
com.hegenberg.BetterTouchTool.plist

(old copies are saved in my home directory just in case)

I'm stumped...

Perry
 

pedz

Registered
I think I'm close to solving this. The UI in preferences is broken. I'm not sure if it is just me or not. I'm on 10.7.5.

What should happen is when I check the "tap to click", then another option use to appear for dragging. If that was checked, the "lock" option would appear. Those two options never appear.

The file to look at is com.apple.driver.AppleBluetoothMultitouch.trackpad.plist. If you format it in xml, then you can see the different options.

So I did:

plutil -convert xml1 -o /tmp/dog com.apple.driver.AppleBluetoothMultitouch.trackpad.plist

edit the file and fixed the DragLock and Dragging options to true. Then did:

plutil -convert binary1 -o com.apple.driver.AppleBluetoothMultitouch.trackpad.plist /tmp/dog

Logged out, back in, and so far it appears to be working.

Not sure what to think about the change to the UI. I don't know if that is just mine or if Apple goofed and removed options that need to be there. I keep thinking that I'm in the wrong place to see those two options.
 

DeltaMac

Tech
Can you change those settings in System Preferences when you are logged in as a different user?
That is, are the settings that you think are missing, also missing for another user?
 

pedz

Registered
I can not find the options that I remember anywhere.

I thought maybe they may be part of the mouse interface so I plugged in the mouse.

As I recall, it was a stair step sequence of three check boxes. And the other two boxes I can't find -- even for the other user.
 

sgould

Registered
I wonder if they have redesigned in line with Mountain Lion. On my new laptop with Mountain Lion the trackpad does not have the tapand drag. You have to use three fingers to drag or else physically press the trackpad down. DIsappointing.

Can you drag with three fingers?
 

pedz

Registered
Oh... I see... Yes, I can drag with three fingers.

Hmm... Had I been introduced to that, I might have preferred it but at this point the tap-drag is sooooo deep into my fingers I don't know if I could change.

But it sounds like maybe you are right. They are trying to change.

So... with that info, I'll paste this:

<dict>
<key>Clicking</key>
<true/>
<key>DragLock</key>
<true/>
<key>Dragging</key>
<true/>

That is at the top of the plist file. The draglock and dragging were false.

My process I described previous can be used to set these even without the GUI interface.

Hopes this helps others but it sounds like Apple is trying to change us.
 
Top