"Disk Image Mounter no longer open" message

haskittens2

Registered
I am on an iMac running El Capitan (10.11.6) and an important file that I store as a ".dmg" will no longer open, as I get the above message.

I tried to open it using Disk Utility with no success. When I open the System Information window, some of the Hardware and Software choices come up with error messages. ("There was an error while gathering this information.") In particular: Diagnostics, Graphics/Display, Hardware RAID, Memory, NVMExpress, & USB. The others do give the information on the hardware installed. However, I do get the same error message when going through Utilities/System Information on almost all of the hardware.

The network choices do show the items. The DiskImageMounter does show up when selected under the Application menu: /System/Library/CoreServices/DiskImageMounter.app

I did open the system diagnostics and got 249 pages of messages which I don't understand. I am not a programmer so I can't understand what's going on.

Is there anything I should do to get my .dmg file opened?
 

DeltaMac

Tech
Is there any change after you restart?
Do you still get the same strange errors in System Information?

If there is no improvement after a restart, the various problems that you report can probably be fixed by a reinstall.
I would suggest that the best way to do that reinstall is to boot to a bootable El Capitan installer.
If you don't have that, and if you have no way to make one, then you can boot to your recovery system (Restart holding Command+r)
Choose "Reinstall OS X" from the menu window. It will download the system files, then reboot to install those files. Should take anywhere from 20 minutes to most of an hour, depending on the speed of your internet connection.
 
Top