Disk utility

alito

Mac fan
I have a problem with disk utility
i select my hard drive, but i cant check or repair the disk
the buttons are alll in grey,
some help?
 

ElDiabloConCaca

U.S.D.A. Prime
What kind of setup are you using? Do you have OS 9 and OS X on two separate partitions? Two separate drives? One drive/one partition? What hard drive are you trying to repair -- the startup drive or some other drive? If you have any other drives, can you select those and have disk utility operate normally?

Providing as much information as you possibly can would help us try to pinpoint where exactly the problem is occurring, since many different things can cause similar effects... thanks!
 

alito

Mac fan
thanxs for your help
im only using one partition
and when i select my hard drive i cant use disk utility.
the verify or repair are in grey and doesnt work
 

ElDiabloConCaca

U.S.D.A. Prime
Hmmm... try booting from the 10.1 or 10.0 Installer CD, then when the installer pops up, choose "Disk Utility" from the menubar under one of the menus... you can run it from there and try to repair your disk. If this still doesn't work, I'm lost!
 

ElDiabloConCaca

U.S.D.A. Prime
I found out specifically why those options are greyed-out under Disk Utility -- apparently, 10.1's disk utility is different from OS 10.0's disk utility. You USED to be able to verify the startup disk with disk utility under 10.0, but it would ALWAYS report errors even if there were none. This was a known issue and Apple even said so -- I guess they changed that in 10.1's disk utility... something to do with the new UNIX underpinnings or something prevents the disk utility from accurately reporting errors on the startup disk?

At any rate, disk utility will not check or repair the startup disk, nor will it do so for any disk that has open files on it, and, obviously, it won't do it for read-only disks such as CD-ROMs and write-protected disks. Disk utility reports this when you try and select one of those volumes.

Best bet: boot from the OS 10 installer disk and follow my directions as per my last post. That's the only thing I can think of, short of booting back into OS 9 and running the Disk First Aid program from there...
 

alito

Mac fan
thanxs a lor for your attention
i will try that
 

Dradts

Official Mac User
startup ur mac while holding down command+s.
this will boot into the single user mode (this won't load the aqua interface, so there is no gui in the single user mode!).
on the then appearing shell type "fsck -y" to check ur harddrive for errors and to repair them automatically.

run the fsck command like 3 or 4 times, cause it never fixes all harddrive errors at once.

after the hd is fixed, type reboot
 

twyg

Back to Mac Baby!
-y assumes yes for all questions, unless absolutely necessary to let the user know something. It's very much like -rf for rm, which as we all know is "just remove the fuc!$r! ;)

If you've ever got a question twister on a type of command, just type man, and then the command. So it's "man fsck"

That's how your's truly learned what I know about *nix... :D
 

Jabberwocky

A World Without Windows
I have a 3 80Gb SCSI Seagates running on an Adaptec 39160 in a G4 Quicksilver running OSX Server. I used the Disk Utility to combine them as one 210Gb volume using RAID 0.

The other day, the machine froze (I thought OSX had proper memory/process management...) and on restart I was presented with the message that I was attempting to mount disks with no readable volumes.:confused:

Oh f... thought I as there was 80Gb of work on there un-backed up as I had literally just recovered the data from the previous server that had consigned itself to bin.

Disk Utility can see the disks and can also see the RAID volume. When I ask it to verify the RAID, it says Keys Out Of Order and that the volume needs to be repaired. After pressing the Repair button, I again get the message Keys Out Of Order and then Repair completed, but it clearly isn't as the volume is still missing.

I placed a call to Apple support who told me to get into Single User mode and run FSCK -Y which I have done, but that only seems to run on the ATA boot disk.

1. Can I run FSCK on the disks attached to the SCSI card?
2. If so, how do I tell Single User Mode to change to another disk?
3. Failing the above, has anyone got any ideas how to fix my RAID?

G4 Quicksilver DP800
1.2 GB RAM
Adaptec 39160 with 3 x Seagate 80Gb
 

blb

`'
fsck -y does only do the boot volume, so you are correct in it not doing any others. In order to do the others, you need to know the device entry being used for the filesystem. For example, if I want to also check my OS 9 partition, I have to run

Code:
fsck_hfs /dev/rdisk0s9
since disk0s9 is the OS 9 partition. If you know the disk devices for the RAID, run the above for it and you should be good. If you don't, we need more information, specifically, the output of ls /dev/rdisk* to find out what other disk devices are out there, then try the fsck_hfs against those. If it's not the right partition, fsck should just error out, so move on to the next one.

And in case anyone is curious, if you do something other than fsck -y you'll probably have to use fsck_hfs for an HFS/HFS+ volume as it will otherwise assume a different filesystem type (I'm guessing UFS?)
 

boomw

Registered
I'm trying to take your advise, the thing that's bothering me is I can't figure out why something would work only sometimes? There has to be something that changes in order to cause the problem in the first place. I'll let you know after I reboot how everything went.
Thanks,
B
 

edX

mac shaman
just curious, are you sure you have enough free space on the drive and/or enough free sectors. i so not know about disk utility in this area, but i know other disk repair programs need space to rewrite the corrections. they also must have enough good spare sectors to write on.
 

boomw

Registered
This is an elderly 2gig APS drive.I have my Win2000 image on it which is taking all but about 250mb of space. It is chock(sp?) full.While I was unable to repair the disk with the Disk Utility in OS X or with the fsck in the terminal window I have successfully repaired the disk in 9.2.2 with Disk First Aid. Now the disk shows up fine. Now for the real test. Will it show up in OS X? And what can I do to prevent this from happening in the first place?
Thanks. Someone up as late as me! Cool!
 

edX

mac shaman
well, tell us how it went.
and i don't know where you are but it's only about 10.45 my time. (CA)
i'm on the board almost every nite about this time
 
Top