Duel Boot Of Macosx & Kali Linux Failed On Mbp Tb! Install Of Grub Failed. Can't See Kali On Boot.

Discussion in 'Boot Camp & OS Virtualization on Mac' started by Twi'lek, Nov 25, 2017.

  1. Twi'lek

    Twi'lek
    uix_expand uix_collapse
    Registered

    Joined:
    Nov 10, 2017
    Messages:
    1
    Likes Received:
    0
    I know this might not be the right place to ask this, but I thought it was worth a try. I'm totally a beginner at all of this. But, I'll try to explain where my Kali Linux Install to my hard disk fails...

    I'm currently running Mac OS X High Sierra 10.13.1 on a late-2016 MacBook Pro 13" with TouchBar. I'm trying to install the 64-bit Kali Linux 2017.3 from a USB to my hard drive on my MacBook Pro, so I can run it as a duel boot with Mac OS X. I can successfully boot into a Live Session of the Kali Linux ISO image on my USB. I made a partition on my hard drive for Kali Linux using Disk Utility on Mac OS X. The partition is in MS-DOS (FAT) and MBR formats; it is 69G in size. I then attempt to install by choosing "Install in Graphical Mode" from the "Advanced Options" choice from the Kali startup menu. During the Graphical Mode Installation Process, I run into 4 main errors that are preventing me from successfully running and using Kali from my hard drive after installation.

    I select all the applicable settings for language, keyboard layout, etc. I run into my first problem when it tries to detect hardware for my network. It says I'm missing a file "brcm/brcmfmac43602-pcie.txt" and asks if I want to load it using removable media (photo of what the screen says: https://imgur.com/UQt3OuI). I've tried downloading that file from my browser onto a USB. But, when I try to load it during the install, the installer won't detect it. It just shows the same prompt again from the photo above.

    I then skip that step and continue. When I get to the network setup stage, connecting to my WiFi fails. I think I managed to get the WiFi connection to work by adding in the IP addresses for my computer and router manually, but I'm not sure how to confirm that the connection is actually working. It just continues the install after manual input of my IPs, but it ever shows a WiFi connection confirmation that would tell me I'm actually connected to the internet.

    At this point, the installation process continues. I next run into a problem when trying to set up mirrors. None of them work. So, I skip that step too.

    The last problem seems to be the most important, and the reason I can't load into Kali from my hard drive. The problem is with the GRUB install. It fails completely. It says, basically, "fatal error detected: GRUB failed to install", or some variation of that. But, it doesn't tell me WHY it fails to install. So, I finish the install without it, and reboot. Now I do have rEFInd installed, and it IS working. But, when I reboot at this point, rEFInd is not detecting the freshly installed Kali Linux on the hard drive. I can only boot into my main Mac OS X or the Kali that's on my USB stick.

    I'm assuming me not being able to see Kali on the hard drive has something to do with GRUB not installing, and not the other 3 errors I'm having. If someone, ANYONE has successfully installed Kali on a late-2016 Mac Book Pro, PLEASE help me! I'm going to post this on Kali's forum as well and hopefully between the two forums someone has successfully done this duel boot. Thank you in advance to any replies to this post.

    -Twi'lek
     
    #1 Twi'lek, Nov 25, 2017
    Last edited: Nov 26, 2017

Share This Page