erratic mouse behavior

mjbjohn

Registered
This is follow up post to a continuing problem with my apple optical pro mouse. The mouse won't track all the way up the screen nor will it track sideways at all. I received several suggestions from my original post but they didn't help. The last suggestion was to restore my system via time machine to a date prior to the issue;however, I have tried doing that and it still doesn't help. During the restore process, the mouse works; after the restoration is done and the computer restarts; the mouse doesn't work. The mouse is connected via usb to the usb port in the keyboard; I tried a new mouse but no change. I have run hardware test and disk utility and everything is fine; I also tried reinstalling snow leopard but no change; the mouse seems to work fine during these tests but not after restart.I am at a loss and appreciate any help. FYI: the computer is a macpro.
 

ElDiabloConCaca

U.S.D.A. Prime
Try creating a new user account and see if the mouse problem persists in that new user account.

If not, then that points to something localized to your specific user account, and we may be able to trace it down.

Also, just for future reference, it's considered "bad form" to post NEW threads asking the same thing over and over again. If your issue isn't resolved, please continue to use the existing thread you originally started to troubleshoot the problem. Posting a brand-new thread covering the same problem only serves to annoy people on here as well as clutter up the forum with duplicate, unresolved threads -- and that serves to no one's benefit.

Let's chase down the problem, but let's do it all within a single thread! :)
 

mjbjohn

Registered
Thank you will try your advice respond with the results. My apologies for the breach in etiguette;I am little flustered.
 

mjbjohn

Registered
I set up an admin account and it worked for a while but then the mouse reverted back to the erratic behavior. I first upgraded my snow leopard software thinking that might help with the main user account but again it works for awhile and then reverts to the previous behavior. I also tried a wireless mouse but its affected as well.
 

mjbjohn

Registered
Well after a trip to the apple store where they found nothing wrong and some trial and error the culprit appears to be my belkin 7 port usb hub. As soon as I disconnected it from the computer, the mouse worked fine. I tried plugging in the hub to another usb port and the mouse didn't work so it must be the usb hub or one of the devices connected to it. Next step is to remove each device one by one to see if it is the culprit rather than the hub itself.

Thanks to everyone for their earlier suggestions and I would be interested if anyone has had issues with their usb hubs. Thanks
 
Top