ethernt not working


I have two macs at home, an emac and an older imac. A friend of mine wants to buy the iMac so I thought I would get it all up to date for her.

But when I went to connect it to the Internet and update the software it says
"Make sure your network is configured properly and try again"
And when I try to connect to the Internet it says
"Cannot find server"

So I tried configuring the network according to apple help and it still didnt work.

I asked my dad who unfortunately know less about macs than I do and we still couldn’t figure it out.

We plugged the connection back into the emac and hey presto it worked and in the network panel automatically comes up with the following as soon as the cable is plugged in "Built in Ethernet is currently active and has the ip address You are connected to the Ethernet via built in Ethernet"

But when we plug the same cable into the imac, nothing. All it says in the network panel is "Internal modem is not set up" nothing about Ethernet.

When we go into the system profiler and network it sees the built in Ethernet, and details it as:
Configuration name - built in Ethernet
Interface - en0
Type - Ethernet
IP Address – (there is nothing here)
Ethernet address - 00:0a:27:92:c9:d4

Can anyone tell me if I can find out if my Ethernet (the hardware) is working? Or if I have another problem? and how to sort it?

We have had a look on other forums and have tried resetting the NVRAM.

We have also tried holding down the apple, alt and O and F keys and tying in a phrase when you get to the white screen, which basically tells us the same as the network preferences do.

Any help gratefully received.


U.S.D.A. Prime
Open "System Preferences" then "Network." Under "Show:" choose "Network Port Configurations."

Check to make sure that "Built-in Ethernet" has a checkmark next to it, and also optionally appears at the top of the list (the top-most interfaces are accessed first for network activity).