External CD/DVD drive no longer recognized - HELP!

srichardson

Registered
Hello -
I've spent the better part of two days trying to resolve this problem, to no avail. I'm running Mac OS 10.4.2 on a G4 Desktop. Suddenly, the Profiler no longer recognizes my external CD-DVD burner, QPS Que-Fire. I thought perhaps it had something to do with Tiger, but the drive worked fine for a few weeks after I upgraded to Tiger.

I've just wiped my hard drive and done a complete clean install of my system software, and everything else is working fine. I've repaired permissions, also, as suggested in another post.

I know the drive isn't bad - I took it home, hooked it up to an identical Mac there, and it worked fine.

I'm out of ideas. Can anyone help?
 

ElDiabloConCaca

U.S.D.A. Prime
Does your computer recognize ANY external FireWire devices?

You can try an NVRAM reset (non-volatile RAM), as this sometimes helps resurrect "dead" FireWire ports. Restart your machine and hold down Command-Option-O-F as it boots. At the prompt, type "reset-nvram" (without the quotes, of course) and press Enter, then type "reset-all" (no quotes) and press Enter again. The machine should reboot.
 

ElDiabloConCaca

U.S.D.A. Prime
Are you connecting the external DVD drive to the same port as the LaCie drive, or a different FireWire port? Have you tried connecting it to a different FireWire port? Have you tried daisy-chaining the devices? Did you try the NVRAM reset? What exactly have you done to try and fix the problem in the last two days?

Please be more specific, otherwise all we can do with the information you've given us is just throw random suggestion after random suggestion at ya... telling us all the information you think would help us diagnose and troubleshoot the problem would be good, but all we know is that you've got a G4 (which model?) that won't recognize a device that is recognized by one other computer.
 

srichardson

Registered
Thanks for the help...here's what I can tell you...

The back of the G4 has two firewire ports. I've tried the burner in both of them; no recognition. The LaCie drive IS recognized in both of them.

I've tried a new firewire cord, and a new power cord. The device is getting power, as the light is on.

I've reset the permissions, and have also done a complete clean install of Tiger.

Just tried the NVRAM reset, and there was no change.

In the Profiler, it just lists two Firewire devices: the LaCie external drive, and "Unknown Device"

G4 running 10.4.2 - Dual 500 MHz - 2 GB SDRAM -
L2 Cache (per CPU): 1 MB - Memory: 2 GB - Bus Speed: 100 MHz
Boot ROM Version: 4.2.8f1

Thanks for your help!
 
Top