external hdd problem



I purchased a 250 gb samsung ata hdd, and I bought a manhattan External 3.5" Enclosure which uses USB 2.0 connection. You can see the enclosure at
everything works fine under windows xp however when I plug it into my powerbook, i cant see the drive. i checked the system profiler, i can see it under USB High Speed Bus as a USB 2.0 storage device, but I can not access it.
It is NTFS formatted and cant be accessed under disk utility too.
What should I do?


From experience if you want to see it under OSX and Windows XP it will need to be formatted with fat32 which both XP and OSX can see (Linux too) NTFS tends to be pretty much M/S only although later Varients of Linux can read but not write it. I'm a Mac newbie so this may not be the definitive answer :)


U.S.D.A. Prime
Mac OS X has the ability to read NTFS volumes only, but can read and write to FAT32 volumes.

Your Mac should "see" and mount the NTFS volume, and I don't see a reason why it wouldn't. If you don't have much data on the drive that you need, I would recommend reformatting the drive as FAT32 and see if that helps.


I have a Fuzitsu 2.5 80gb It won't show up either on my MAC G4 powerbook.
I reformatted to FAT32 no luck. I tried another USB device 8-1 Belkin Media reader and same result. Is there a trick to tuning on USB devices on the MAC i am missing?