External Speakers Not Working Anymore on OS X, can't Edit Preferences

Bob32

Registered
I'm about to go out of my mind here so some help would be much appreciated. I just hooked up some new speakers to my Mac desktop which has been giving me some trouble recently. The last set of speakers I used stopped working. I thought it was the speakers since I tried an older set that didn't plug into an outlet (the other set did plug into an outlet), and the older set worked. Well now I just moved, got a new set of Bose speakers, and they were working fine for about 10 minutes. Then I paused the video I was watching to talk to my wife, and when I played it again, there was nothing.

The volume icon at the top can't be edited. i can't edit anything in sound preferences, and the only thing that comes up in output and input is "DigiCore Audio Device" and I have no idea what it is; not my Bose speakers. Now that I know it wasn't the speakers, I'm sure it's the Mac. It's a version 10.6.8 if that helps, and I tried shutting everything down, unplugging all USBs, everything in the back of the computer, then started it back up. Nothing. I tried plugging it into the audio jack in the back of the computer, I tried in the front, I even tried plugging it into a USB Soundwave 7.1 (which is how it was working for that first 10 minutes today) and that didn't do anything either. I was going to try and reset the PRAM, but I have a wireless Wave Logitech keyboard and I can't figure out what the Command key is. I'm at my wits end here and I really can't afford a new computer here, so I'm really hoping to get this problem solved and get the sound working again. Thanks in advance.
 

DeltaMac

Tech
You do need to try a PRAM reset.
By default, the Windows key on your keyboard should be sensed as the Command key for use with keyboard shortcuts on your Mac.
If the wireless keyboard doesn't produce the reset that you want, then you could use any USB wired keyboard. Borrow one if you don't have one somewhere.

Your Audio device is actually Digi CoreAudio Device, not DigCore Audio Device.
Look in the folder Macintosh HD/Library/Audio/MIDI Drivers to see if anything that is related to your external audio devices is found there. You could simply try removing whatever device file is showing in that folder, then restart your Mac.
Other possibilities here: http://www.google.com/search?client=safari&rls=en&q=DigiCore+Audio+Device&ie=UTF-8&oe=UTF-8

Assuming your difficulty is software related (perhaps some corrupted drivers, or older drivers that are not as compatible as they could be.)
You might also boot to your OS X DVD, and reinstall Snow Leopard. A simple reinstall may, as one result, clean up some of the "cruft" that you may have accumulated in your system software. That reinstall will not disturb your own software and files. You would then run Software Update to get your system fully updated.
 
Top