FAT32 External Partition Won't Mount


Recently I purchased a LaCie 500GB external hard drive (http://www.lacie.com/uk/products/product.htm?pid=10651). When I first connected it to my computer I was still running Jaguar, and it would not mount. It showed up in disk utility but wouldn't mount from there either. I assumed this was just because it was perhaps not compatible with 10.2, so I just made one partition in Mac OS Extended format so that I could back up all my files before performing an erase and install of Tiger.

After getting Tiger installed, I tried using iPartition to make a FAT32 partition so that I can still share photos etc with my Windows using friends. This partition will not mount either. It also shows up in disk utility but I am unable to mount it from there.

I've done some searching around this forum and a few others, and tried using the sudo mount command in the terminal after creating a directory on my internal, but I just get the message:

mount_msdos: Unsupported sector size (0)

I checked the System Profiler and under the USB tab, the drive shows up, but only the Mac formatted partition shows up under volumes.

Is there any other way I can manually mount this, or have I been using the sudo mount command incorrectly?

I'm running an iMac g4 PowerPC with the latest update of Tiger.

ps - I also noticed in iPartition that there is an option to format partitions in something called "DOS FAT32 (<= 2GB). I made another partition using this but it's doing basically the same thing, the only difference I can see is that in disk utility it says:

Format : MS-DOS File System (FAT32)

rather than:

Partition Type : Windows_FAT_32

And also that the first FAT32 partition I made cannot be verified or repaired, but the second one can, and when I try, it gives me this error message:

Verify and Repair disk &#8220;disk1s12&#8221;
** /dev/disk1s12
Invalid BS_jmpBoot in boot block: 000000
Error: The underlying task reported failure on exit

1 non HFS volume checked
1 volume could not be repaired because of an error

pps - I just tried doing the method described here: http://forums.macosxhints.com/archive/index.php/t-38412.html

And I got this message in the terminal:

disk1s11 device will attempt to be mounted ...
***Disk Appeared ('disk1s1',Mountpoint = '', fsType = '', volName = '')
***Disk Appeared ('disk1s2',Mountpoint = '', fsType = '', volName = '')
***Disk Appeared ('disk1s3',Mountpoint = '', fsType = '', volName = '')
***Disk Appeared ('disk1s4',Mountpoint = '', fsType = '', volName = '')
***Disk Appeared ('disk1s5',Mountpoint = '', fsType = '', volName = '')
***Disk Appeared ('disk1s6',Mountpoint = '', fsType = '', volName = '')
***Disk Appeared ('disk1s7',Mountpoint = '', fsType = '', volName = '')
***Disk Appeared ('disk1s8',Mountpoint = '', fsType = '', volName = '')
***Disk Appeared ('disk1s9',Mountpoint = '/Volumes/LaCie', fsType = 'hfs', volName = 'LaCie')
***Disk Appeared ('disk1s11',Mountpoint = '', fsType = '', volName = '')
Disk Mounting Completed

But it still isn't mounting!


iMovie Professional
I would use Disk Utility to run a disk check on the drive. Once that is done, format as Mac OS Extended on Disk Utility, and verify you can write to the drive. If all works well, open Disk Utility and format as MS-DOS (aka FAT32).


So you mean the only solution is to reformat the whole drive thus erasing everything and having to back it up first? I can do that.. I was just hoping I could find a less time consuming method.


iMovie Professional
I think it'd be faster to back it up and reformat. It'll be faster than looking for another solution, if any. Also, it looks like something with the format may have gone awry, so you may have future problems if you don't reformat.


Okay, I'll try backing up and reformatting in FAT32 first, see if that gives me any problems. Thanks, if I find anything else I'll post back here though because I saw that there were a few other people will not dissimilar problems who had not found a solution either.