Firefox and Safari Slow/Non-Responsive

txcabo

Registered
I have an iMac:

Model Name: iMac
Model Identifier: iMac6,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2.16 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 4 MB
Memory: 1 GB
Bus Speed: 667 MHz
Boot ROM Version: IM61.0093.B07
SMC Version: 1.10f3

I've only had it for about 3 weeks, and about a week ago both of my browsers started slowing down. I run Firefox primarily, and routinely, especially if I'm quickly clicking through a site, the internet slows down, then sometimes will just become non-responsive.

It seems to do it most with site with large amounts of information. I write articles for music magazine sometimes, so I frequent band's myspace pages, and Firefox will not load the media flash players. Never in the last week. Sites with lots of graphics/media/etc get boiled down to a base html view and sometimes appear that way.

Sometimes, when the browser is just spinning...not loading any pages...I'll turn Airport off and then on again. Typically this lets me click to one more page before it all slows or freezes again.

I thought it might be the internet (we're using AT&T's new Uverse), but my new HP laptop browses just fine. Then I thought it might be Firefox, so I uninstalled mine and then reinstalled it. Still not working. I tried Safari and it does the same thing.

I don't know much about troubleshooting Macs.....any ideas?

Thanks for any help.
Lucas
 

Satcomer

In Geostationary Orbit
Just go to the folders /Library/Internet Plug-Ins/ and or /Users/YourUserName/Library/Internet Plug-Ins/ and find the plugin that is messing with your browser.

Plus run a maintenance program like Yasu or Onyx and run all the cleaning routines rebooting twice after the cleaning to rebuild the startup/shutdown cache. This will clear you cache that might have become corrupted.

Good luck.
 

SteveMarshall

Registered
I had this problem with Firefox, Chrome and Safari. Followed many sites suggestions, repaired permissions and trashed just about everything, then /// following some simple logic went to user/SystemFolder/Internet Plug Ins moved out the three Quicktime plugins and everything worked, perfectly
 
Top