Firewire firmware deleted?

streetlightpoet

Registered
I just recently got an internal maxtor 120gb HD and a link depot external fw/usb case for it. I hooked it up and it worked fine, however there was a firmware update for the case that I figured I might as well download, when I went to run the updater it said to unplug all firewire devices, so I did then clicked update. Now neither of my firewire ports recognize any devices I plug in. I can use my HD over usb, but it is a hassle to do so, when I try and use it via FW it doesn't mount or show up in any way shape or form anywhere, however, if I run the updater again with the hard drive plugged in it does show up, but when I click update nothing happens. When I plug in my ipod over FW it recognizes it as an external HD but not as an ipod (won't show up in iTunes, although it does open itunes upon plugging in)
I am not a computer expert at all, but I am guessing I messed up/deleted my firewire firmwear? Does anyone know if this is indeed the case and what I should do regardless to try and fix it?


Also I saw something about being sure to remove the jumpers if using a HD over fw when looking over old threads to try and get help, can someone explain that too me in terms of if that is something I should go back and do?

Thanks in advance for the help!
 

ElDiabloConCaca

U.S.D.A. Prime
You should set the jumpers on the hard drive to the case's specifications. The case should specify how the jumpers should be set, so refer to the manual.

You might want to try zapping your PRAM (hold command-option-p-r at startup and keep them held down until your computer restarts 3 times). If that doesn't work, resetting the NVRAM may help (boot into open firmware [command-option-o-f at bootup], then type "reset-nvram" then "reset-all" [without quotes]).
 
Top