Firewire Ports Dead


Hello, i have notice that both my firewire ports are dead. my ipod, external hard drives, anything i try.
the ipod looks like aconnection is being made, but freezes until i unplug it.
there looks like some voltage is present (hd light flickers).
any ideas?

machine name: power mac g4
machine model: powermac3,4
cpu type: powerpc g4 (11.3)
number of cpus: 1
cpu speed: 533 mhz
l2 cache (per cpu): 1 mb
memory: 1.25 gb
bus speed: 133 mhz
boot rom version: 4.2.8f1
serial number: rm22500al86
sales order number: f0255ll/a

ati radeon 9000 pro:

chipset model: aty,rv250
type: display
bus: agp
slot: slot-1
vram (total): 64 mb
vendor: ati (0x1002)
device id: 0x4966
revision id: 0x0001
rom revision: 113-99703-112

grappler_906f scsi card
usb 2.0 pci card

osx 10.4.2

Try booting into open-firmware and resetting the NVRAM.

1. Boot/restart your computer and immediately hold down command-option-o-f until you reach the open-firmware screen (you'll know it when you see it).

2. Type "reset-nvram" (no quotes, of course) and press enter.

3. Type "reset-all" (no quotes, of course) and press enter.

See if that gets your FireWire ports working again.
I have same problem on Mac Mini using 10.4.3. Tried your suggestion but still dead.

Any other possible explanations?
Are your FireWire port(s) completely dead? How many FireWire devices have you tried with the ports? Are you sure it's the port, and not the FireWire device (hard drive, iSight, etc.) itself?
Had a similar problem yesterday and today. Suddenly, when I connected a FW device (first my Maxtor OneTouch II, then my iPod), I had a kernel panic. First I simply rebooted and tried again, and it worked once. Afterwards, it again produced a kernel panic.

Today I searched the forum, found this thread, saw that my Apple System Profiler showed "no information" for FW and panicked. Reset the nvram in OF, reset the PRAM twice for good luck and am up and running again. However: I have no idea why this happened, which makes me a bit nervous. Is my FW port dying? I certainly hope not, since I ain't got the money for one of those intel iBooks or PowerBooks that hopefully come out next month just yet... :/
I've got same issues with fire wire ports on a g. Any more advice would be great. I have: zapped PRAM, reset nvram, tried devices on other computers (they work fine), reinsatlled (Archived) a new operating system and run a tech. tools pro diag (FW doesn't show up!!!)...any more advice?????
G4...just missed the "4"... Any advice? The only thing I haven't tried is replacing the battery (tomorrow) and completly reinstalling os. Aybody out there got some advice for the growing number of editors who's firewire has gone toes up?

I've just found myself with dead Firewire ports on my eMac after an apparent surge last night (wasn't home).

I just found this thread, so I'll give these ideas a try and let you know how it goes...
Well, apart from the issues mentioned earlier in the thread, where probably a software problem or "small surge" caused the problem, a _real_ power surge can of course actually fry the electronics inside your Mac. I'd go to your Apple dealer of faith and have them look at it.
I hope this isn't the issue, but when my firewire ports on my powerbook dies some time ago, it was a defective logic board, which i had to get replaced (thankfully i had applecare). If nothing else works this might be the cause, but for your sake i hope not.
So can anyone explain why a Hardware Test tells me that my logic board is ok and it passes the test? Also, when I plug my iPod into the FW port, it charges but it just won't appear available. This tells me that the FW ports work but obviously still have issues.

Any other ideas? I'm on a serious budget and I'll need to sort this out soon as I have a home-based business that is being affected by this.

Thanks for all of your ideas, I really appreciate the help.

Having the same problem as others. Tried the nvram,pram,file sharing, new cable and still cannot access my external HD. It just doesn't show up on the desktop or on the system profiler. I'll keep monitoring for solutions and will add if I find answer else where.
Do your _Firewire_ ports show up in Apple System Profiler? Because then it's _not_ the same problem and it's rather your harddrive than the FW ports at stake...
Is there a way to test the FW ports? OR anything I can do to get to the HD to test it? If it is bad can the data be retrieved?
Well, a major success was accomplished. I got my hard drive back and it has to be version 10.4.6 where at I do not know yet but I have my hard drive back. I started up from the Tiger install disc. Held down C and rebooted, then looked under the Utility menu and looked at system profiler and there it was. So I knew it wasn't the cables nor the hard drive. Someone suggested installing Tiger on the external drive...I did that, and copied my prefs and info from my computer's hard drive it rebooted from there and I am operating off the external with my mac showing up in the external drive space on my desk top. so far everything is working well.

Eventually I will reboot from my computer's hard drive as soon as 10.4.6 gets fixed.

Good Luck
I have a G4 (Sawtooth) with dead FW. The above Cmd-Opt-o-f fix had no result--more about which in a second...No FW, no trace of it on Profiler. Just went out in the middle of burning a CD two years ago. In the meantime, I got a G4 MDD, but since there's no $ in trying to sell the old one, I tried to revive it. (Everything else worked--just no FW function; no recognition of FW devices; I tried several.)

I'd been told that these machines were notorious for having the FW chip blow out on the motherboard. Only fix--new motherboard. OK, found a 450MHz direct replacement on eBay. Swapped MBs out--no change.

Tried the fix above. Monitor stays blank and tells me, "Input 2-No Signal." I've tried this from a restart, from a cold start, never any variation in results.

What needs to be done to revive FW in this G4 desktop? (AN ipod will charge--but not show up on the desktop--if that means anything...)

This is still running OS 9.1. What else? Factory 10G HD; 640MB RAM; no major tweaking, customization or add-ons (I'm an arts graduate and given to technical concerns only out of a sense of necessity, not pleasure, recreation or personal fulfillment.)