G4 450MHz B&W installation problems


Perhaps someone can help with an installation problem. I've searched these forums and haven't found anything similar to what I'm experiencing.

I have a G4 450MHz Blue and White. 384 MB of RAM. I have two internal drives: the original 6 GB and a Maxtor 120 GB.

Mac OS 9.2.2 is installed on the 6 GB drive, and I'm attempting to install Tiger on a 20-GB partition on the Maxtor drive.

I have no trouble booting from the DVD. It goes through the installation procedure just fine, but when it reboots, I get the gray screen with the apple and a spinning graphic at the bottom. After a minute or so I get the "prohibited icon."

I've zapped the PRAM.
I've upgraded my firmware.
I've run the repair permissions utility from the DVD, and the repair disk utility.
I don't have anything plugged in but the original keyboard and mouse (and a microphone and speakers and phone line)--all other USB and FireWire peripherals, as well as my track ball, are disconnected.
I've tried reinstalling.
The disk checks out good; the Mac seems to know it's there and has OSX installed on it. The fact that OSX boots from the DVD leads me to believe it can't be a hardware issue. I have no problems booting from the OS 9.2.2 drive or the DVD--it's just that I'm getting these kernel panics when I try to boot from OSX.

Does anyone have any suggestions? I've never had this sort of trouble with a Mac before, and it's starting to confirm my initial prejudice against Mac moving toward a more UNIX-ey OS.

Thanks in advance,
Unless you have a processor upgrade, the B&W Power Mac comes with a G3 processor. Besides, depending on the revision of the motherboard on that B&W system, it might not support the slave drive. For more information, see here.

BTW, how much capacity is showing on that MAxtor 120GB when you view it with the OS X DVD install? If it's not the full 120 GB, then you might need an IDE controller that will support that size drive, becasue the built in IDE controller might not be new enough to support it.
Perhaps I erred in referring to it as a "Blue and White". It's indeed a G4. PowerMac G4 (API). The installer sees the full 120 GB (partitioned as it is into 5 different drives).

Any other suggestions.
WHat type partitions are they? Are they Mac OS Extended with Journaling? If you made them UFS, then you might have to redo them in order to run some applications.

Have you tried swapping the order of the drives (make the 120 GB the master and the 6 GB the slave)? I'm not sure if OS X likes to be installed on secondary hard drives. If you swap them, you can have Mac OS X boot as the primary drive and then head to System Preferences-->Classic to point the system to the Mac OS Classic System Folder in the 6 GB drive.
The partition I was trying to install to was Mac OS Extended with Journaling. I finally got it to install after the fourth time. And the only thing I did differently was waiting the "30 seconds until reboot" rather than hitting the reboot key right away.

Yes, I know it's stupid, and it's probably magical thinking to believe that that had anything to do with it, but there you go.

MacOS X rocks, by the way.
I had some initial troubles with Tiger as well when I first installed it -- errors on the first install, successful install but kernel panics the second time, perfection the third.

Many people report having trouble going back to Panther after installing Tiger, as if our machines just took some "getting accustomed to" Tiger, and now must "get reaquainted with" Panther to function normally.

I can't explain it, but glad to hear you got it working.