G4 scsi card/zip drive no bueno

dave17lax

Inventor of the Egg Wave
When I bought my current G4 I got a scsi card from Apple with it to run my scanner and zip drive. Fast Fwd 2 years, once I got on OSX I had to buy a new scanner, and haven't used the zip drive until....today.
Except that it doesn't work.
This may or may not be a software or hardware issue, but I need to get my data off of those stinking zip disks.
Symptoms:
None, it doesn't work. No drive shows up in System Profiler or Disk Utility. SCSI card DOES show up in AppleSysProf.
Have installed newest adaptec2930 scsi driver, only to find out I already had it installed.
Installed latest Zip100 scsi OSX driver. When launched, states there is no zip drive attached.
Zip Drive is set to termination: ON and have tried both 5 and 6 on the chain (the only choices on the drive).
Mac: Dual G4 500 OSX 10.2.6, 832 MB ram gigabit ethernet, 2 internal HD's, internal DVDROM, external Que Firewire CD_RW
SCSI PCI Card: Adaptec 2930 scsi card in the 1st pci slot. (graphics is AGP)
Zip Drive: Zip100 scsi drive, multiple zip disks/ vendors tried, but none work as the drive is not recognized.
Mac plugged in, Zip Plugged in, power ON

If anyone knows what this might be, holler at me.
 

DeltaMac

Tech
Probably the only way to copy files from Zip disks with a SCSI zip, is to boot up into OS 9, should work fine. (that's the cheapest way)
OR, find a USB zip
OR, find and install an IDE ZIP internally
OR, hookup your SCSI ZIP to an older MAC with SCSI support, copy to other media.
OR, Swap your SCSI card with one that support OS X, like the ATTO brand, (limited cards in this line support OS X)
SCSI is not the simple thing it once was on Macs.
 

GraphicUmp

Registered
The Adaptec 2930 is FULLY supported by OS X - in fact, the driver's installed WITH OS X. I don't think the card's the problem (I use the same card at home, but with an internal hard drive); I think the Zip drive, or the support for a scsi zip drive, is the problem.

Try either booting into 9, as DeltaMac suggested, or using a Classic application to open then "save as" whatever files you need.
 
Top