Hard disk doesn't get further than grey screen with Apple logo


OSX 10.4.11 (Tiger) PPC G4 733 MHz

My Tiger volume gets stuck when starting up, it doesn't get further then the grey screen with the Apple logo. The clock with stripes keeps working but it doesn't get me to the blue screen.

For compatibility reasons concerning different softwares i use (Protools, Reason etc...) i keep changing the internal HD's for years now, thus changing the OS's (10.3.9, 10.4.11 etc). Never caused any problem.

When i boot from another 'master' volume (f.e. 10.3.9) OR from the OSX install CD, putting the Tiger volume as 'slave', in order to verify its disk permissions or the disk itself to be able to repair them, it's 'invisible', not 'seen' by the other volume. So no 'verify disk permissions' nor Combo Update possible, maybe those things could solve my problem.

My cables are working perfectly: making the exact same connections and jumper settings with all my other volumes, is no problem at all: every volume is correctly seen by the others. Also, there is no USB or external firewire device connected while trying to start up.

Remark: never had any problem with this Tiger volume, starting problem only occured yesterday AFTER installing Toast Titanium (which worked normally), shutting down and trying to start up again. Nevertheless, some minor problems occured beforehand these last days: some apps didn't work anymore, like Safari, itunes, installer and UnrarX. But i don't know if it's linked.

What could be the problem?



In Geostationary Orbit
Boot with the Tiger install disk and use the installer menu items (before proceeding with the install) to find Disk Utility and see if it can repair the disk. If it can't the either replace the drive (I most definitely believe you NEVER BACKED UP!).


Ofcourse, that's the 1st thing i did, but as you can read in my troubleshooting mentioned above: When i boot from another 'master' volume (f.e. 10.3.9) OR from the OSX install CD, putting the Tiger volume as 'slave', in order to verify its disk permissions or the disk itself to be able to repair them, it's 'invisible', not 'seen' by the other volume..
In fact, this troubleshooting isn't complete: that's just part of what happens when trying to start up: in some cases, my PPC sometimes only 'sees' the Tiger volume that unfortunately gets stuck on the grey screen, but skips the install Cd when i try to start up holding the 'c' key. Very strange.

So to sum it up, 2 possibilities, apparently depending on the 'mood' of my PPC:

1. install cd is ignored while holding 'c' key, Tiger volume tries to start up but freezes at the grey screen, no other volume that could run the much needed disk utility is seen.

2. none of the volumes is seen (install cd, other HD, nor Tiger volume, ...) when holding the 'alt' key, resulting in the famous 'questionmark'.

Either way, i'm screwed... until someone gives me someting new to try!

ps: in the worst case: i can still back up in Target disk mode, can't i? I have a brandnew external portable Hd (USB 2.0) with 250 GB free space for that.


You could try target disk mode. Then if the drive doesn't mount to whatever you are connecting it to or if the machine its connected to starts acting flaky (i.e. spinning beach ball, error messages such as "disk utility could not repair this volume", etc..) then that's a good clue the drive is on its way south.


1. I guess that only works through firewire? Tried to install OSX on my iomega blank self-powered, formatted external drive (could start up with 10.3.9 from another normally working internal drive), to boot from there, but it says that install is only possible on the internal drive (external drive has 250 GB free space). I guess it's because it's a USB drive and not a firewire drive?

2. is it normal that - supposing my Tiger drive itself is broken- a broken drive is NOT recognized, seen, if i put it in slave position? I thought even broken drives were seen by start up OSX's, as long as i don't try to start up from those drives themselves.

3. the drive didn't move an inch (physically) between the last start up where it still worked perfectly, and the next start up where it got stuck on the grey screen (merely a few minutes after). So how can the drive be on its way south? 'Cause that's would be a hardware problem. In other words: still think it's a software problem, 'cause problems occured after installing toast titanium 10, shutting down, and starting up again.

4. if i understand well, back-ups from the Tiger drive are not possible anymore with any external Mac and Target disk mode if it's a hardware problem/broken drive?

5. or could it be this problem? Just remembered that these last few days i had to insert the admin password during start up (guess i accidentally chose a password protection). But then again, now the computer's stuck before, on the grey screen.


At the end of the day, this is an extremely troubling development. Yes, there might be a way to turn this around, for now, but I'd not be confident about where this might be heading in the next few months. Let's be clear: it has absolutely nothing to do with Toast. It's entirely likely it has to do with a hardware fault, either of the Mac or the hard drive. At some point, you're either going to encounter a service bill or a replacement bill for the hard drive. The question you face is how much and when do you want to pay. Were I you, I wouldn't really bother trying to salvage your current setup.

The quickest, safest resolution to this is to remove your problematic drive, and insert an older drive you've got lying around. If the older drive works the first time, then you can fairly safely assume it's a problem with the drive. The best solution is then to get a new drive, and do a fresh install from the Tiger disks. Then you can get a external drive enclosure, put the problematic drive in that, and hopefully rescue your data off the drive through a firewire hook-up. If you have Apple Care, I'd definitely recommend you let them deal with it. That's what you've paid for, after all. If you're not under warranty anymore, then it's really a question of whether you're going to pay an Apple Store the money to play around with this thing, or whether you just pre-emptively solve the issue by installing a fresh drive.

If, however, you want to play around with this, or you don't currently have any money to spare, then I've got three possible avenues for you to explore.

Press and hold CMD (apple key) + R + P + CTRL. Then turn on the system, continuing to hold all four keys. Wait until you hear the "dong" sound twice. Release the keys. See if that encourages it to boot. If not, repeat the process, but I guess go ahead and let it dong three times. Then release. If this works for you, great. But understand that this particular situation you've described is a warning. It does mean something is going wrong with your machine or your hard drive. Expect for it to happen again until you solve the hardware problem that caused it in the first place.

If those "magic" keys fail, let's try something else. Every Mac has a hardware reset button on it somewhere. Problem is, it's in a different place on every machine. Check Apple's website for instructions that pertain to your particular machine. This little reset button could help you out if the "magic" keys don't.

If neither of these simple solutions work, then it's not really a matter of whether there's a hardware fault, but instead where that fault is. The steps below will help you decide whether you just need a new hard drive or a trip to the Apple Store:

Boot with one of your other boot disks (let's call it, "Fred") and look at your volumes through Terminal.

That is, boot with Fred and go to the Utilities folder and run Terminal. At the prompt, type: cd /volumes

At the resulting prompt, type: ls

This should give you a list of all the volumes that boot disk has ever seen. If your problematic Tiger disk (let's call him "Sam") has ever been online during an instance of Fred being in charge, then Sam will show up as one of the possible directories. If you do see Sam, check that you only see Sam. If you see a "Sam 1" or "Sam 2" or "Sam <insert a number here>", you've got a problem that's described below.

If Sam is there, type: cd

[If Sam is not there, you can stop at this point. Sam's absence means you have nothing conclusive to go on. His absence probably just means you've never booted from Fred while Sam was around. Thus, you can't use Fred to give you any information about Sam.]

Then type, cd /volumes/Sam

If you get an error message at this point, you're probably screwed. If however, the prompt changes to reflect the fact that you've successfully changed over to Sam's directory, type: ls

[Note that getting an error message after attempting to change to Sam's directory doesn't absolutely mean you're screwed, either. It could just mean that you directly copied a previous boot disk &#8212; maybe even Fred himself &#8212;*onto Sam when you first installed it, instead of doing a clean install from Tiger disks. Doing this will actually copy a "ghost" of every drive to which the old drive had ever been connected. My current boot drive, for example, lists disks in its /volumes directory that its predecessor had been friendly with several years ago, even though it had never been connected to those drives at all. Thus, when I try to change to those disks I get an error message. In order to successfully switch to an invisible drive, the current boot disk must have been actually connected to the now-invisible drive at some point.]

If you successfully switch to Sam's directory, ant typing ls gets you a listing of the root folders of Sam, you might be okay. One possible cause of such a condition is incorrect drive settings. Not every internal HD can successfully be used as a boot drive, even if they have on occasion done so. You may need to refer to the website of the drive manufacturer to get specific details about whether that drive is capable of being a Tiger boot drive (again, even if you've successfully used it as one in the past). Ensure that you have the pins on the hard drive set up correctly to be a master.

Or it may be that you have faulty wiring inside your Mac. It could be something as simple as the drive failing to receive the proper amount of power to spin up correctly. A sign of probable power problems would be the existence of multiple Sams, as described above. These "other Sams" are usually caused by unexpected power loss, and the drive subsequently coming back online.

If you don't get a listing of the root folders, you're probably screwed. But again there could be some kind of pin/power problem.

You can test for this pin/power problem by removing Sam from the Mac and re-inserting an older drive that you know to have worked in the box before, say "Jimbo". If Jimbo successfully mounts, then you know it's most likely not a hardware fault with the Mac, but with the drive itself. If Jimbo produces exactly the same results as Sam is doing now (failing to move beyond the grey screen), then you know you have a Mac problem, not a drive problem.

At this point, you're likely in a world of hurt. I'm not sure how you could go forward with the drive, after you've eliminated the issue of faulty wiring/power supply.

In the above example, please substitute Sam, Fred and Jimbo with the real, current names of your drives.
Last edited:


First let me just say thanks a million for all the help, i learned a lot! Thanks for your time, such a long response must have taken quite some time. RESPECT!
Needless to say that from now on i'm backing up everything.

Just managed to recover it, it's starting up OK now! In fact, all of a sudden the Tiger volume was seen by the 10.3 volume just before i wanted to try your solutions, so i managed to run disk utility after all. There was one necessary repair, and it was successful! Don't know what caused the problem though, it would be nice to know so i can avoid this in the future. *

* Reserved fields in the catalog record have incorrect data_
Checking volume bitmap.
Volume Bit Map needs minor repair_
Checking volume information.
Invalid volume free block count_
(It should be 176668 instead of 176656)
The volume TIGER needs to be repaired.