HELP. Black Screen/Blinking but inactive cursor Starting From Windows Install Disc

#1
First off, please do not say anything about how old the hardware and software is. I have been using this all successfully for years and this has never happened. Do not tell me about upgrading, I have software and plugins that I need which I have attempted to bring forward in time and I can't.
______________________________________________________________________________________________________________________________

I have an Early 2008 MacBook 2.4 GHz Core 2 Duo (T8300), MB404LL/A, Model A1181 (EMC 2242). I upped it to 6GB of RAM (it only "sees" 5GB but I've heard that is how it goes). I just now stepped up to a 500GB SSD since my HDD got corrupt and died. I rescued everything off both the Mac and Windows partitions so I just need to reinstall from scratch. I've done it numerous times before. But now as I'm trying to install XP, I get the infamous "black screen of death" I'd never heard of til now. The fix for this is usually "boot off the original install disc and fix from there" except the install disc is what is getting me the issue. The keyboard also seems to be non-responsive, so pressing F8 or F11 does nothing.

Possible variables I have explored:
It's been tried on two different black macbooks, also tried on a brand new 1TB HDD and an original 250GB HDD (in case the issue was XP not playing nice with the SSD). I also bought another brand new XP Home Edition disc with SP3 and the same issue occurs with that as with the one I already had.

Here's the kicker: I GOT IT TO WORK ONCE and I don't know how. I restarted with Boot Camp Assistant (in Leopard, the last version that expects XP to be an option - once XP is installed I can then upgrade the Mac OS), got the black screen. Rebooted and tried to eject the disc, but apparently a little bit too late. It blinked black and then flashed and suddenly I was in Windows Setup screen. I installed XP but then had numerous issues which I thought were due to it not being done smoothly using the Assistant, so i went back and wiped the partition and started over.

I am at a loss as to why this isn't working all of a sudden and why it did during one attempt. The only reference I have been able to find to this issue has someone suggesting it's "a hardware issue" but I'm not sure what that would be in 2 different macbooks.

Another thing that comes to mind is the fact that you need BIOS compatibility and an MBR partition table (or hybrid GPT/MBR) to boot from Windows on a Mac, so are either of those things somehow set wrong or not present on these macbooks? And if so, how can i check? I don't want to fuck around in BIOS and ruin the whole machine, unless someone knows exact steps to look in there and check what's up.
 
Last edited:
#2
Working my way up from the bottom:
Macs do not have BIOS, so there is no way possible for you to muck around in BIOS and ruin anything. All you would need to do is reset the SMC, then reset NVRAM. That would be a good next step for you. Here's how I do that:
Remove the battery, disconnect the power adapter, press and hold shift-Control-Option and the power button. Hold those for 5 to 10 seconds. (nothing will happen that you will notice in any way)
Release, then insert the battery, and connect the magsafe adapter.
Wait for 10 seconds before doing anything (the Magsafe adapter plug should light up)
Press and release the power button - immediately press and hold Option-Command-p-r.
You should get a boot chime. Keep holding the same 4 keys until you hear the boot chime two more times, then release the keys to let your MacBook boot normally.

I have the exact MacBook that you have. It should recognize 6GB of RAM (all of it), unless that is some anomaly of Win XP. OS X should see it all.
Try booting with each memory stick, by itself, and make sure that each is recognized for the full amount, 2GB and 4GB, respectively. Reinsert both, make sure that they are seated properly. Memory sticks in those older MacBooks always make a subtle "click" when fully seated.

The resets that I listed above are something that I use quite often on that old MacBook, as I struggle to use OS X 10.10.5 - with similar software needs as yours, but I need a newer system, not an older one. (I have Windows 10 installed on this MacBook, too, which has issues finding drivers for some of the internals -- doesn't affect my use, as I mostly just need to wifi card to work! )

Keep in mind that the internal keyboard, and the trackpad are connected together, and are on the USB bus, along with the bluetooth card, the camera, and the IR receiver, so could simply be some problem with the USB drivers on the XP install (not picking up devices properly), so be sure to try another wired USB mouse and keyboard to see if the XP install goes more smoothly. If you don't have any wired input devices, it might be a good time to find a set to borrow.
Do you still have your original OS X restore DVD for your MacBook? That would be the one that has the bootcamp drivers on a hidden partition, and gives you the best chance of getting Windows XP working, with all devices setup and working.
 
Top