HELP PLEASE! Can't See Printer - WHY?


I am trying to use my new OfficeJet 7410 and it does not show up in any choices. the printer see's the Powerbook (Tiger OS), but the PowerBook can't see the printer...WHAT AM I DOING WRONG?
Nobody can help me to understand WHY my printer see's my PowerBook, but my PowerBook can't see my printer? I reinstalled, deleted, reconfigured, must be something!
Just because you didn't get a reply in an hour and a half doesn't mean no one knows why this is happening... plus, you didn't provide much information to go off of other than you've got an OfficeJet 7410 and a PowerBook with Tiger.

How are you connecting the printer to the PowerBook (USB, ethernet, wireless, etc.)? What steps are you taking to add the printer to the OS?
Trying to set it up for wireless printing with my Airport. Did a computer-to-computer network, tried the add printer and it will not display the hp officejet...tried repair permissions, rebooted, reinstalled, recreated new networks, turn on AppleTalk, etc...