I am trying to install the newest version of hotspot shield onto my mac (I have downloaded the program before), but during my installation I get a message with a big red exclamation mark saying 'You cannot install Hotspot Shield on this volume'
The latest version of Hotspot Shield requires a minimum of OS X 10.6 or later.
You get the message window, because your OS X version is too old, and not supported by Hotspot Shield.
Scroll down to the system requirements at the bottom of the site's info page: http://www.hotspotshield.com/en
You can't run that latest version, without upgrading your OS X, which you can easily accomplish.
Why not just continue to use the older version, if it still provides you with the VPN that you have been using?
If you have the free version, you could simply move on to something else.
If you paid for the Elite version of Hotspot Shield, then you could post a tech support message at their site. And you could find out if the older version is still available direct from them.
You would want to check that you have more than 1GB of RAM memory, as Snow Leopard needs that much as minimum.
Any MBPro that came with 10.5 originally can be upgraded to at least 4GB, and maybe even 8GB. Your performance, particularly if you continue to upgrade all the way to Mountain Lion (OS X 10.8.x) will be better with 4GB or more, if possible.
That's from a strange download site, which I can never get to work. How do you download files from that site (softonic)?
I refuse to download their "special downloader app"...
Is that what you have to use for that site to work?
got it to download, but appears to be the same "intel-only" version.
I must be missing something...
Can't say I have ever tried, that was just one of the links from a Google search using "Hotspot Shield for 10.5.8" as the search parameter.
I know what you mean about difficult download links, but I'm sure if a person is determined enough that one of those links will get results.