How Am I Going to Delete *.ram files?


On my desktop i have about 20 *.ram files but i can't delete it.
When i tried to delete it, it said

" The item bla bla bla.ram is being used by another task right now. (Other tasks include moving, copying, or emptying the Trash.)

Try again when the other task is complete."

Please somebody help me. I'm running Mac OS X 10.2.8.

Try quitting RealOne Player, THEN emptying the trash. If that doesn't work, logging out or restarting should let you empty the trash.
Already quitting RealOne Player but still cannot delete the files. How am i going to put the files in the trash because it said being used by another task.

I can't even move the files anywhere.
Have you tried rebooting? If any process is holding onto them, that'll fix it. Just logging out would probably do the trick, too, but rebooting definitely will.
Yup! I've tried rebooting and logging out BUT the files STILL can't be remove.

FYI, these files have been in my desktop since last year. Can't move it, can't trash it and don't know what to do.

01. Launch 'Terminal' ('/Applications/Utilities/' folder).
02. Enter 'rm -rf ' (do not include the single quotes; but, do include a space after 'rf').
03. Drag the '.ram' file(s) you want to delete onto the 'Terminal' window. As a result of the drag, you will see the full path of each dragged file listed.
04. Click on the 'Terminal' window (just to make sure it is the front most process) and press the <return> key.
After i press return key:

Command Not Found.

Is it because i deleted realone player?

I also tried to put the files into Terminal window without keying rm-rf
but still permission denied.
It's 'rm -rf' -- note the space between the 'rm' and the '-rf'.

The full command in the Terminal should look like:
rm -rf /path/to/file1 /path/to/file2 /path/to/fileN
'rm' is a command, '-rf' are the options, /path/to/fileN are the complete paths and filenames of the files. Each item should be separated by a space.