How: Stop Youtube fullscreen making 2nd display unusable?

wicky

play thing
System:
OS x 10.8.5, MBP, additional 22" monitor via DVI mini display port.

Problem:
I'm trying to follow a Youtube tutorial on the MBP display, and operate SketchUp on the larger screen. I wish to make youtube fullscreen to see the detail, but everytime I click the full screen icon the 22" display is made inactive (grey linen).

Question:
How can I stop this happening, so the Youtube clip just occupies the MBP at full screen?

Background:
This often happens with youtube clips, but not always. About 50% of the time clicking the fullscreen icon results in Youtube clips (and other video) just occupying one screen without the grey linen on the other. It seems random and appears to be something I have no control over.

Ideal solution:
If possible I'd like to permanently disable the grey linen effect. I can't think of a single time when this has been beneficial for me. I use my computer as a work device rather than for entertainment, so I always want access to both monitors independently.
 

DeltaMac

Tech
This would be a good opportunity for Mavericks, as there's been various changes in Mavericks that may your multiple screen issues.
(The grey linen is gone in Mavericks, as one example - and multiple screen support has changed significantly, allowing menu bars on all screens, plus other changes. Some would say there's not useful improvements, but you might test for yourself.
more info: http://www.apple.com/osx/whats-new/#multiple-displays
 

wicky

play thing
Yeah, I would… but, you know… I'm kinda loosing faith in Apple very quickly. Isn't Mavericks yet another Windows-esque release: premature / insufficiently tested?

Whereas I was always an early (and evangelistic) adopter of Apple's new releases, since they started pushing an iPad oriented paradigm on OS X updates have been consistently terrible (in my experience). I just can't risk the downtime associated with yet more problems. Some of the less mainstream software I use is bound to not work correctly.

Isn't there a command line hack to stop the issue?
 
Top