how to always Turn on Verbose Booting on OS 12.3 on a M1 MBP?

ChangeAgent

Registered
In the good old days of Intel Mac, you entered

Code:
sudo nvram boot-args=”-v”

in Terminal and it worked. I tried this on my M1 MBP and it did not work. On the internet I did not find much information. One titbit I found is here: https://eclecticlight.co/2020/11/28/startup-modes-for-m1-macs/
Howard states there: However, this no longer appears to work in macOS 11.2 and later.
However, on my Intel MBP’ with 12.3.1 it works fine.
He also states: You should also be very careful when working with NVRAM settings on an M1 Mac: any errors or problems may require a complete system reinstall, apparently.
Does anybody agree with that in case of activating Verbose Mode?

So, two questions:
1. Is it possible to activate and if so how?
2. Any dangers that anybody is aware of?

Thanks.
 

Satcomer

In Geostationary Orbit
Nope I'm sorry to say, that was Intel ONLY! It wasn't even allowed on AMD systems either! Right on on M1 or better we need to find other ways to fix issues on the newer Macs!
 

Satcomer

In Geostationary Orbit
The only way I see right now is boot into recovery mode and laughing the Terminal app fixes to fix problems!
 

Satcomer

In Geostationary Orbit
fsck -fy is a code that fixes old hard drives but now with built in SSDs I'm sure now!

Plus learn Terminal commands here to get you started! You can use the buluit inappropriate to start practicing. Another cool command is cal yearyouwant like cal 1752 to see the calendar change to current calendar!
 
Last edited:

Satcomer

In Geostationary Orbit
I'm not brave enough to do it on SSDs but external hard disk I can do through the main Terminal on this externals DAS devices!
 

DeltaMac

Tech
I'm not brave enough to do it on SSDs but external hard disk I can do through the main Terminal on this externals DAS devices!
OP was asking about enabling verbose boot mode, and wants to know if using that verbose boot setting will actually work after a reboot.
So, your post appears to say that you have successfully set verbose mode, using an external boot drive.
If so -- Did you then try a restart from that external drive to see if it reboots to verbose mode?
Howard Oakley, a pretty knowledgable guy @ Eclectic Light Company, seems to think that is not a supported boot mode on M1 Macs
 

Satcomer

In Geostationary Orbit
OP was asking about enabling verbose boot mode, and wants to know if using that verbose boot setting will actually work after a reboot.
So, your post appears to say that you have successfully set verbose mode, using an external boot drive.
If so -- Did you then try a restart from that external drive to see if it reboots to verbose mode?
Howard Oakley, a pretty knowledgable guy @ Eclectic Light Company, seems to think that is not a supported boot mode on M1 Macs
Doing from the main account! I wish you would have noticed that!
 

DeltaMac

Tech
I didn't notice that.... But, then it does appear to me that you might be answering on the wrong thread.
The OP here doesn't appear to have any problem with using the terminal.
But, the terminal commands (at least one of them) do not seem to work on AS Macs.
The real issue for the OP is that AS Mac's firmware do not appear to support some of the boot modes, such as verbose mode.
(This is in no way a user account issue) - and AS Macs can potentially be damaged by a previously-minor error in typing, or maybe even damaged by simply trying one of the commands that worked on Intel Macs.
At least that is something that is mentioned as a possible result on that Eclectic Light company information page.
 
Top