How to disable or at least change the spotlight hot keys?

angryswede

Registered
I use the key commands in illustrator / photoshop all the time and when i do the "option / apple / spacebar" or "apple / spacebar" commands to zoom out, the spotlight window(s) open.

I've tried opening / changing the key commands numerous times, as well as disabling them with no luck (they just reset to the standard ones). it's not a huge deal, but it is rather annoying.

Maybe one of you guys has had a similar problem and figured out a fix?

thanks
 

bobw

The Late: SuperMacMod
Have you tried disabling the Keys in the Spotlight PreferencePane?
 

bobw

The Late: SuperMacMod
Try trashing the Spotlight Preference file 'com.apple.spotlight.plist'
 

Lt Major Burns

"Dicky" Charlteston-Burns
zooming on photoshop/illustrator is apple- and apple+

intead of trying to supress something deep in the system, just supress the need to change the photoshop bindings.
 

ElDiabloConCaca

U.S.D.A. Prime
Because sometimes you need to zoom-in to a defined area, say, someone's eyeball -- instead of hitting command-+ and command-- until you get to the desired zoom distance, then panning over to the eyeball, you can simply hold down command-space, then click-drag a box around the eyeball, and it'll zoom directly to the area you selected.

Much handier than repeatedly pressing command-+ over and over.
 

fryke

Moderator
Staff member
Mod
Yeah, I *HATE* how people can't leave Apple-Spacebar alone. Apple has previously tried to use it for changing between input methods and now uses it for Spotlight. I don't get it: Do they just _ignore_ graphics designers like me who're using Macs and Adobe software for more than a decade? Makes me angry. I'm using Cmd-Space in Adobe software all the time, because

a) Cmd-+ is not available on a Swiss German PowerBook keyboard (The plus sign is "Shift-1" there)

b) Cmd-Space lets me work in a controlled environment, whereas Cmd-+ always zooms the center of the current view, which obviously doesn't help if you want to enlarge something that is _not_ at the center of the screen.

For me, setting Spotlight's shortcut to Cmd-§ works fine. Doesn't change back to Cmd-Space.
 

angryswede

Registered
bobw said:
Try trashing the Spotlight Preference file 'com.apple.spotlight.plist'
i'll try that. thanks!


ElDiabloConCaca said:
Because sometimes you need to zoom-in to a defined area, s...
precisely. plus option - apple - keyboard is right where my left hand sits (as well as the other main adobe shortcut keys), the + / - keys are across the keyboard, which would defeat the purpose of it being faster.
 

Lt Major Burns

"Dicky" Charlteston-Burns
sorry, i knew straight away that i'd be blasted for that post. at which point, thought, if it is only sometimes you need to use the maginifying glass, why not click on the magnifying glass on the tool bar, like i do.... :D
 

ElDiabloConCaca

U.S.D.A. Prime
Lt Major Burns said:
if it is only sometimes you need to use the maginifying glass, why not click on the magnifying glass on the tool bar, like i do.... :D
Because keyboard shortcuts are faster.

Plus not everyone zooms infrequently. I zoom frequently enough that without the keyboard shortcut, working would be a pain.
 

fryke

Moderator
Staff member
Mod
I dunno what the "§", ah yeah, springs to mind now. Something with legal things. Law paragraphs or something. I don't EVER use that key, so Spotlight's good there. ;)
 
Top