[HOWTO] Fix User lost Administrator privileges

Satcomer

In Geostationary Orbit
I was follow the blog MAC OS HELP AND TIPS and cam across a great tip to fix Leopard lost Administrator privileges. THere is first the Apple Document Mac OS X 10.5: Administrator user changes to standard that talks about using the Install disk to reset the master password. However there is a Terminal way also the MAC OS HELP AND TIPS blog came up with:

Shut down the computer if it is on.
-> Press the power button to start the computer.
-> Immediately press and hold the Command (Apple) key and the "s" key for single-user mode.
-> Type "mount -uw /" and press return.
-> Type "passwd" and press return.
-> Enter new password (this will be for the root user account) and press return.
-> Type "reboot" and press return.
-> Enter Account settings and when prompted for administrator account and password, use the user name root and the password you just setup
-> Check box for you standard account to administrate box
-> If all goes well you are admin again.
I will add to this, please DISABLE the root account after you do this, or at very least, use a good, strong password."

I hope you can use either the install disk trick or via this Terminal way.
 

freikorpsco

Registered
Boot single user, find short name of user ls /Users
1) mount –uw /
2) launchctl load /System/Library/LaunchDaemons/com.apple.DirectoryServices.plist
3) dscl . append /Groups/admin GroupMembership (short name)
no need to enable root or use a install disk

also if you simply want to read which users are on the admin list -
dscl .read /Groups/admin GroupMembership
this can be done from terminal or single user
 

sms

Registered
Hello,

I've been trying to fix the privileges on my user for over a week now and just gave up and decided to ask for help. Ive read all posts I could find on the web but none of them worked, so I'm explaining below the problem I have and would appreciate any help.

My Mac was working OK with 10.5.8 when I installed the 10.6 update. For some weird reason, my user just lost all root privileges, in spite of showing that my user does have the privileges. When using the dscl command, but it shows that my user is included in the admin group. When looking at the user management panel in Settings, it shows the " let this user administer this machine" checkbox marked, but it is gray and dont let even the root user change it.

But, when I try to do anything that requires privileges, such as changing any configuration that requires authentication, or updating any software or even 10.6.1, it just dont let me. It is like I didnt have the privileges to administer the box.

Has anyone seen this kind of problem? Any idea of how to fix it?

Thanks in advance.
 

Satcomer

In Geostationary Orbit
Yes. Boot with the 10.6 disk and before the install happens go to the menu items and in the Finder menu (on the install disk) hunt around the menu item to find "reset Administrator password". Reset the password and boot back into normal mode. Then in system Preferences->account change the password back to what you want. Then you must reboot your Mac one more time to let that password set in throughout the Mac.

I had this happen to me back in going from 104 to 10.5 on a clean install and this process fixed my problem. Hope it helps you.
 

sms

Registered
Thanks Satcomer, but that didnt help either, since the problem is not with the root user, but with my personal account, and the root user was not able to change my profile either.

But I found the solution to my problem to be pretty easy to implement, after I found this thread in Apple foruns:

http://discussions.apple.com/thread.jspa?threadID=2204597&tstart=150

Quoting the solution described by donv (The Ghost):

"Try this solution. If it doesn't work, then we can think about reinstalling.

Go to ~/Library/preferences/ByHost/ and delete all com.apple.HIToolbox files.
Restart your Mac.
Go to your user account preference pane.
Unlock the lock
Type your password.
Lock the lock.
Try installing whatever you are having problems with again. "


And it worked great. After reboot, when I clicked on the lock, it prompted for my user and password, and the lock when unlocked. After that, everything worked great.

I thought I should share this with everyone in this forum.

Thanks.
 
Top