iBook suddenly can't find WiFi net

mike flugennock

Registered
iBook G4 with AirPort base hooked to DSL router.

For no reason just now, the iBook is suddenly unable to find the AirPort base station in our house.

Repeated resets of the base station haven't worked.

Resetting the DSL router also hasn't worked.

Repeated reboots of the iBook also haven't worked. Usually, at boot time the iBook automatically finds the house net and logs itself on.

Before this issue occurred, network response was slow, and I was unable to access the G4 over the house LAN.

The iBook now returns the message "There was an error joining the AirPort network (network name)"
 

DeltaMac

Tech
Does your home network appear in the iBook's Airport menu?

Do you have other devices that connect to your home wireless network?
Is the iBook the only system that won't connect to your wireless network?
 

mike flugennock

Registered
Everything appears normally in the Airport menu. Nothing has changed that I can see, between the time the network was working normally and when the iBook lost contact with the house net.

There's one other device, my wife's MacBook Pro, which is still able to connect. I'm also still able to log onto my wife's MacBook from my G4 minitower (which has a normal "wired" connection to the router).

I tried something yesterday which I found on a list of problems and solutions on a CNet forum, which was to create a new network (with a similar name to the "problem" network, so I could ID the house net). The "problem" network used WEP Personal authentication, with that hashed-up random character string a mile long; this other forum article suggested WEP might be the problem, so I created a new network using WPA authentication with a normal English character string that I could remember for purposes of the test.

I'm able to access the house wifi over the newly-created network from the iBook, though I still have issues with the speed of logons and file transfers over AppleTalk from the G4 tower.

I also tried reconnecting the iBook via the "old" network setting (WEP); the menu showed 4 bars, but neither Firefox or T'Bird could find the Internet, and I couldn't log onto the iBook from the minitower. So, I went back to the workaround solution for now.
 

DeltaMac

Tech
Your other thread here
http://macosx.com/forums/mac-os-x-s...58-airport-occasionally-drops-connection.html
states that your wife's MBPro also loses the wifi connection to your Airport - but in your post #3 here, you said that your wife's MBPro can still connect OK (?)
If you lose the connection on both laptops, and roughly at the same time, then I would suspect that your base station is getting flaky.

Always check in your Airport menu for OTHER wifi networks, that perhaps are causing some interference on your wifi signal.

You also said that you created a new network. Did you do that through your Airport menu (where it says "create new network"), or some other method?
Or, did you just create a new "location", which allows you to use different settings (such as a different name) for the same network connection?
Keep in mind that you CAN'T just arbitrarily change the wireless encryption protocol from WEP to WPA. That setting depends on how the airport base station is setup, and you can only change that security protocol in the settings on the base station...
 

mike flugennock

Registered
Sorry that post was so confusing.

What I was meaning to say was that while the wifi connection was up and working, all the machines on the house LAN were visible, both wireless and 'wired'; the occasional wifi signal droppage was a different issue -- when the wifi drops out, both notebooks disappear from the house LAN, and the notebooks are unable to 'see' the G4 tower... and yes, this happens about the same time on both the iBook and the MBPro. Unplugging the base station and plugging it back in restores the signal.

Re: creating new network: D'ohh, my goof there. What I did was to create a new location (thanks for catching that) with the same name as the current house wifi location, appended with '02'. The original house wifi location is still set to WEP (the long random hash password), and the new '(location name)02' location was set to WPA Personal with a 'human-readable' password. I'm able to access the wifi from the iBook via '(location name)02', but not through the original location (WEP), the one in question, which mysteriously quit working (four bars, but can't access internet or house LAN).

The Preferred Networks list window has accumulated a fair amount of items over time, mostly far out of range -- a coffee joint I hang out at in the 'burbs sometimes, a friend's house on the other side of town, the condo my wife and I stay in when we're in Mexico.

I also see lots of fairly close networks in the menu as well -- four or five neighbors' houses, a couple of locations in the school half a block down from our house. I live on a block of old row houses, and I'd say at least two thirds of the locations that come up on my menu are all right on my block, sometimes two in one house, so there's signal spewing all over the place -- and that's not even counting all the mobile phones and cordless phones (like the two mobes and the cordless landline phone at our house alone).

When accessing the house wifi with the '02' test location from the iBook, switching on 'Interference Robustness' seems to help a bit, but I'm still puzzled as to why the original location setting would work perfectly all this time despite the multiple wifi/mobile phone/cordless phone signals flying all over the block, and then suddenly quit.
 

DeltaMac

Tech
I am STILL confused.
You can not connect to an Airport Base Station (or any other wireless) which has security enabled, unless you use exactly the same protocol for the security. In other words, you can't have two different "locations", which are set up to use the same network, yet use two, very different security protocols.

What security protocol is used within your base station? You have to look at the base station settings. It will either be OFF, or WEP (not a recommended setting, by the way), or some form of WPA/WPA2
 

flugennock

Registered
OK, got it. Both of the "test" locations for the same base station are deleted.

In the meantime, after trying a couple more suggestions, everything seems to have worked out, and we're back to normal here.

I went into the Preferred Networks list, and cleared out all the networks that had been automatically added to the list except for our house net, and the setting for the condo we stay in every year in Mexico. I went in and re-entered the WEP password I had saved in a screen shot I took before I started fiddling. I clicked "Apply Now", rebooted the iBook, went to the AirPort menu, chose the house net, and everything came up normally; the iBook found the house net, was able to find the other two computers in the house, and access the Internet.

If I were to reset the house net to WPA/WPA2 Personal, would I be able to use the same password? Not to make things any more confusing, but when some friends came to house-sit for us last year while we were gone, I had to set two passwords: one a normal human-comprehensible English password for our friend's iPad, and another -- the long random-character hash, which I assume was automatically generated -- for his fiancé's Windows laptop. Both worked at the same location, though I don't really know enough to understand why.

Once again, I hope I haven't made things even more confusing; I'm basically describing what happened, as it happened. Thanks, again.
 
Top