Imac OWC 3G Mercury Electra SSD not in Disk Utility


Good Evening,

So I am having an issue with the OWC DataDoubler kit. Here are the facts:

OWC DataDoubler Kit:

System Information:
Model Name: iMac
Model Identifier: iMac11,1
Processor Name: Intel Core i7
Processor Speed: 2.8 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 12 GB
Processor Interconnect Speed: 4.8 GT/s
Boot ROM Version: IM111.0034.B02
SMC Version (system): 1.54f36

Steps taken:

1. Installed OWC Data Doubler Kit (DDK), powered on, drive not in disk utility.
2. Uninstalled DDK and connected SSD via external SATA/USB to my MBA. Drive popped up right away, and I was able to initialize/format the disk without issue. I copied about 1GB worth of data to the drive without error. I repartitioned the drive.
3. OWC sent me a replacement SATA cable, reinstalled DDK, still not showing up in disk utility.
4. OWC asked me to uninstall DDK and reinstall optical drive to verify the other system components. Reinstalled Optical drive and it is recognized and works just fine.
5. Connect DDK SSD to Imac (destination system) via USB, drive is recognized right away.
6. Uninstall optical drive and reinstall DDK, still not showing up in disk utility.
7. Reset PRAM, SSD still not showing up in disk utility.
8. Support call to OWC to investigate the issue.

Is there anything else I can do to try and make this work or something that I am missing?

Previous post describing the project:
from that OWC page that you linked:
*Professional installation of Data Doubler into an iMac is highly
recommended due to degree of installation difficulty

Looks like you get to find out why they recommend installation....

So - next step - check the seating of the (other) end of the iMac's optical drive cable. You have to pull out the logic board, as that cable connects to the back side of the logic board.
I understand why you could think that...
But, it's still a part of the connection where you haven't tried a replacement with the SSD.
I'm not convinced that you can rule that cable out, just because it works with a different type of storage device.

The SSD is usable on another connection (external case), and OWC sent you a replacement adapter cable. The only part that you haven't verified with the SSD is that original internal connection cable.

For another check, in addition to Disk Utility, when installed through the Data Doubler - does your SSD show up in the System Information (System Profiler if you still have Snow Leopard)?
It should appear as some kind of device in the SATA section - with the expectation that it would show with much the same information that you should expect in the Disk Utility.

And - yes, it's now (unfortunately) a much more involved repair.
Good Morning,

Ok, so i updated from 10.8.2 to 10.8.3 this morning and the DDK is now showing up in disk utility. I am not sure I understand why. My theory is that after the upgrade there is something that goes out and verifies all the hardware that previously wasn't being done and I did not know how to manually perform this "hardware check". I think the problem was def. software related (ML 10.8.2) and I will pass this information back to OWC. Thanks for all your help and hopefully this helps others.