Imac Stuck In Bootup/shutdown Cycle

fpdiver

Registered
I have an iMac (Model details: iMac, Late 2011 model, 27 inch, 4 Gb RAM, Intel 3.4GHz i7) which has recently started shutting down midway through its boot up process (when the Apple Logo is displayed). It continues in that cycle until I turn it off.

When run in Verbose mode, I get the following message:

pid exited (signal 0, exit 1)panic(cpu 2 caller 0xffffff80093cicde) Launchd died\nState at last exception:\n\n~@/SourceCache/xnu/xnu-2782.20.48/bsd/kern/kern_exit.c:363

Debugger called: <panic>


I have tried the following:

  • Cmd - R: (recovery mode) - the iMac doesn’t respond to this and remains in its boot up/shut down cycle
  • Shift: (safe mode) - behaves the same as for recovery mode.
  • I used the Option key to load boot menu - it won’t boot from recovery partition and won’t boot from a bootable installer for Sierra on a USB disk (shuts down again).
  • I used Alt+Option - won’t boot from Internet (tried both WiFi and Ethernet)
  • I have reset the NVRAM
  • I have run memtest86 and the memory checks out ok
  • I ran fsck -fy from single user mode and that checks out OK (but trying to boot after running it gives the same behaviour).
  • I have booted it in Target Disk mode attached to a Mac Book Pro and used Disk Utilities to scan the disk which checked out ok.
Can anyone suggest any other options I can try or help me diagnose the problem? Or is my only hope a genius bar?

I thought it would be possible to install a new OS on the disk via Target Disk mode but I that doesn’t seem to be the case. I’m not precious about any of the files on the disk (and could get them off anyway if needed using Target Disk mode) so if solutions involve formatting the hard drive then that is no problem.

Any help greatly appreciated!
 

SGilbert

Registered
Check this out. If it helps, great, but I suspect your hard drive went south. If so, a new SSD is in order.
 

DeltaMac

Tech
Your iMac is about 6 years old.
Your symptoms are pretty normal for a failing hard drive.
It's a six-year-old hard drive (or more), and has served a good life.
And, you can't reinstall OS X, nor boot to the recovery system (which is simply another partition on the same hard drive)
those again, symptoms of a failing hard drive. You might not be be able to boot until your disconnect that hard drive, as it may be simply blocking other boot options.
It happens. Try a different hard drive.
You will also have the option of foregoing a spinning hard drive, and replacing with an SSD, which will give your aging iMac a new lease on life. It would really be a noticeable upgrade, and make your 6-year-old iMac feel nearly like a newer model.
It's not a difficult job on the older, thick iMacs. You can go to iFixit.com for a list of instructions, along with a short list of the tools that your would need for the job.

One more test, however. Can you boot to Internet Recovery? (Restart, holding Option-Command-R). That boot will NOT show an Apple icon, but will show a spinning globe, and can take several minutes, depending on your internet connection. It will boot to Apple's servers, and give you a different method to test your hard drive. You could even erase your hard drive, then reinstall OS X. The Internet Recovery will give you an option to reinstall OS X, but the version will be the OS X version that originally shipped on your iMac.

However, your 2011 iMac probably shipped with Snow Leopard, so Internet Recovery should offer Lion as a choice to reinstall.
(This is all assuming that you have actually upgraded at some point to a more current OS X)

You never did say what version of OS X was installed now?
If you still have the original, updated system (OS X 10.6.8), then that would explain why you can't get the recovery system (Command-R) to boot. You don't have a recovery system, as that does not install until you upgrade to 10.7 or later.
BUT - the Internet Recovery should boot in any case. That's the Option-Command-R. Again, you will not see the normal Apple icon, but will see a spinning globe during boot.
 
Top