Incomplete website access


My computer is unable to access a part of two websites; parts of other websites too for all I know.

I get no response when I try to enter my gas and electricity consumption figures where required on a UK gas & electricity supplier comparison website (Money Saving Expert's Cheap Energy Club), nor does the alternative payment option window that should appear, do so when I click on the alternative payment option button on a French merchant's website (

Yet all other parts of either website appear to respond properly, at least as far as I have been able to go on them.

But I have no problem when I try the same thing from my daughter's computer, as least as far as the UK energy supplier website is concerned, though I haven't yet had the opportunity to try the same thing with the French website.

Both my daughter and I have Mac computers running Tiger, hers being a MacBook Pro with just Safari, whilst mine is an iMac 9.1 with both Safari and Firefox, together with a VMWare Fusion virtual PC with Windows XP and Internet Explorer. Yet I have the same problem with all three browsers.

Can anyone think why this is happening? What could be the common factor? Is simply reinstating my Tiger OS likely to provide the cure?
Oriole -
I thought you were running OS X 10.6.8 (which is Snow Leopard)
Tiger is OS X 10.4.x - which is really ancient now, and you would likely have glitchy problems when accessing some more modern sites.

I would suggest upgrading both Macs to Snow Leopard - which would at least allow you to use more modern browser versions.

Even the Internet Explorer in your VM would be limited to IE 8? under XP.

I would be curious about why you have the SAME problem in both IE and your Safari/Firefox. Those are not using the same operating system (obviously) - although I suppose that the network connection is all through your OS X system.
You may want to delete your various network .plist files, and restart, then set up your network connection again.
Do these sites use Flash? Apple turned off Flash by default in their latest upgrades. You may need to turn it on again in Preferences.