Instant Messaging Problems Using a .net Passport

Liza

Registered
When having an IM conversation, I am suddenly no longer receiving the other party's messages, but when I ask if they are still there, they can see me - we can then continue the conversation for a few lines, until the problem occurs again.
I've got the newest (bestest!) mac mini, and I also just got an ibook, same problem on both.
I was using a hotmail account, someone suggested I try a new hotmail account which I did, to no avail. So now I'm using my e-mail address with my ISP (Mweb in South Africa), and got a .net passport for it in order to use that address on msn messenger - still no luck!
I've tried all above options on msn messenger and on Adium, all with the same results.
Please help!!!
 

Liza

Registered
Having done the following, based on various pieces of advice (thanks, everyone) I'm now able to chat properly on Adium using MSN and Yahoo accounts, and on MSN Messenger for Mac:

open System Preferences
click on Sharing
click on Firewall
click on New
at Port Name, choose MSN Messenger from the drop down list
click OK

click on New
at Port Name, choose Other from the drop down list
at TCP Port Number(s), type in 1863
click OK

click on New
at Port Name, choose Other from the drop down list
at TCP Port Number(s), type in 80
click OK

Close Sharing window.

In Adium:
go to Preferences
click Accounts
click on your MSN account
click Edit at bottom right
click Options
tick the Connect via HTTP box
click OK
close Preferences window.

Hope this helps someone else!
 

Liza

Registered
I'm back again... because I'm still having problems...

I've tried to chat on all (I think) the messenger programs available for Mac that use a hotmail account or .net passport - Adium, Fire, Mercury (current) and MSN itself - and I have the same problem with all of them: I keep getting cut off/disconnected from MSN! No problems with Yahoo messenger or Yahoo ID (although it can be a bit slow sometimes), just with .net passport account.

I'm pretty sure it's got something to do with Firewall and/or related settings, but after months of trying to fix it, I'm about to give up... please help!

Currently the following Firewall ports are all open:
6891 – 6900
1863
80
1080
5060, 9000, 9010 (UDP – typed like that)

including:
Personal File Sharing
Windows Sharing
Remote Login - SSH
and Printer Sharing.

In my most recent disconnected conversation, Mercury logged a "socket fired exception" error.

I'm on a broadband/adsl connection, shared with hubby's pc through ethernet (and he never gets disconnected from msn, btw), using OSX 10.4.3 on a Mac Mini 1.42 GHz PowerPC G4 with 1 GB Ram.

ANY suggestions would be welcome, but apart from the above, please tell me how/where to find what you tell me to look at or for, because I'm still a new Mac user (six months), and on top of that I'm blonde :)

Many Thanks!
 

ElDiabloConCaca

U.S.D.A. Prime
Can you try removing your computer from the FireWall (connect directly to the DSL modem) or putting your computer in the router's DMZ and see if that helps? It would help to narrow the problem down to something with your firewall/router, or perhaps if those suggestions don't work, to a problem other than the firewall/router.
 

Liza

Registered
Hi El

I've got no idea how to remove my computer from the firewall and connect directly to the dsl modem - any suggestions? Also, wouldn't that expose me to a lot of risk, having no firewall protection at all?

Thanks for posting!
 

bobw

The Late: SuperMacMod
What is your DSL modem plugged into? The back of the computer, or to another device (router).

If it's plugged directly into the back of the computer, open the Sharing PreferencePane in the System Preferences and click the Firewall tab and turn it off if it's on.
 

bobw

The Late: SuperMacMod
Could also be your ISP causing this problem. Some ISP's use a mechanism to slow down file transfers, thinking they could be illegal.
 

Liza

Registered
Thanks, will give that a bash right now and update once I have results - but still a bit nervous about turning firewall off...
 

Liza

Registered
Er... just went to do that, was trying to look for the right button, only to discover a little text that says "Firewall Off"... (I did say I'm blonde) :eek:

What now...?
 

bobw

The Late: SuperMacMod
I wouldn't worry about turning off the Firewall, unless you have Top Secret data on your machine :) doubtful anyone will try getting in, and even then, really couldn't do any damage.
 

Liza

Registered
I doubt it's my ISP, purely because I don't have any other connection problems, and can chat on Yahoo just fine, and hubby uses same ISP and never gets disconnected from MSN.
 

bobw

The Late: SuperMacMod
Sounds like MSN is the problem. It's flakey on a Mac anyway.
 

Liza

Registered
I agree there are "issues"... lol... but if millions of other people around the world can get it right, I refuse to give up!

Anybody else got any suggestions? Please?
 
Top