Interesting MacBook wifi connection problem.

Fants

Registered
Hi all.

I'm having an issue with connecting to my wifi for the last couple of weeks.

I have a MacBook intel core 2 duo running osx 10.5.8.

What's been happening is when I start my mb my wifi appears to be connected however when I go to my browser, Mac mail etc. nothing works even though it shows a connection. When I open my drop down wifi menu it shows a tick next to my wifi but still nothing will load. The only way I can get any connection is if I go to "join other network" then "show networks" select my wifi which automatically shows the associated password and click join, this in turn will give me approx 1-2 minutes of Internet use then it stops and won't load anymore.

My wifi is working fine on my iPhone so I don't see it as a modem issue.

I am also using my Mac in two different locations with a different wireless modems in each location and the problem still occurs.

I do know of someone who had a similar issue, he sent his to a tech guy who found a couple of viruses.


Please can someone help.



Thanks in advance.


Fants
 

Satcomer

In Geostationary Orbit
Depends. Did you Upgrade or buy the Mac with 10.5.x on it? I ask this because upgrading to a newer version of OS X can not totally upgrade the network stack keeping it's old network stack.

Also try going into System Preferences->Advanced button, Wi-Fi mini-tab and delete all the saved networks. Then try again. If that doesn't work try one of the steps in my thread [HOWTO] Reset the wireless Airport Card settings in OS X (10.7.x + 10.8.x) and see if any those fixes help.
 
Top