Intermittent Use Function Keys and Command-Tab program switching (OS X 10.5.8)

jasonmehmel

Registered
Hello all,

Recently (within the last week) I've been finding that the keyboard combinations for changing brightness, bringing up the Dashboard, performing the 'Expose all windows' function, and the Command-Tab program switching having been intermittently operational.

In other words, sometimes they're working, sometimes they're not.

It's important to note that all of the iTunes function keys still work... volume control, tracks forward and back, play/pause.

I can't diagnose the problem; I haven't been able to find a link with any of my recent actions on the machine. When it occurs, I've tried purging the RAM, and force-quit-relaunching Finder, but neither of those work. I've also tried unplugging and re-plugging the keyboard, again with no affect.

I haven't seen anything in my googling and searching where anyone has experienced this before, and definitely not where anyone has fixed it... but I'm hoping someone here might have some ideas.
 

DeltaMac

Tech
Can you tell us which Mac you have?

Could be a failing keyboard, which you can test by displaying your Keyboard Viewer:
Open your System Preferences, then the International pane. Click on the Input Menu, and check the box - Keyboard Viewer.
You will see a flag menu appear in your menu bar. Click on that flag, and choose the Keyboard Viewer. You will see an on-screen representation of your keyboard. You can test your keyboard by pressing various keys on your ACTUAL keyboard, which will be reflected on the on-screen version. All combinations of keys can also be tested, showing what you get as a response with those combinations. Any key will highlight when you press, and the highlight will disappear when you release the key. You can quickly see if any keys are sticking, or not responding at all - or even always showing pressed when you are not touching that key at all. My suggestion would be to especially check the various modifier keys (command, control, shift, and so on)
If you find a problem on the keyboard, then the keyboard can easily be replaced. An iMac is simply connecting a different keyboard. A laptop is not so simple - so it depends on which Mac you have.
 

jasonmehmel

Registered
I've got an iMac from around 2009.

I tried that trick, very cool! I never realized that I could test the keys that way.

It doesn't look like the keys are sticking; both command and tab are showing up as responding. Ditto for the function keys, except for when I press the 'fn' key, but the itunes keys are still responsive even if the brightness, expose and dashboard ones aren't.

Though I don't have any evidence, it feels like a software thing... like maybe some software I installed is conflicting occasionally, but not all the time.
 

DeltaMac

Tech
When the function keys appear to stop functioning, do those keys then function properly if you hold the fn key first?

Check in your System Preferences/Keyboard & Mouse pref pane.
The box for "Use all F1, F2, etc. keys as standard function keys" should normally be UNCHECKED, unless you prefer to use the fn key to get the functions as printed on the keys.

Also, if you really don't find anything that helps, be sure to do the keyboard check when your system next seems to have a problem. You may find that changes what you see!
 

jasonmehmel

Registered
Nope, it's not the fn-key setting. I've checked the box for using the F1 keys as standard function keys because I use a lot of programs (including old DOS ones) that look for those keys.

I've been using the fn keys to activate the printed functions (ur-function? apple-functions?) for a couple of years now. This situation is relatively recent.

Actually, I was having the problem when you suggested the keyboard check, I'm not now, and I'm getting the same response. That's what's got me thinking it's software related... some sort of variable is changing...
 

DeltaMac

Tech
Then I tend to agree that you have a software issue.

You said this is relatively recent. Have you started using some new software - or using your existing software in new ways?

If you restart your Mac, does the problem go away, at least for some period?
You could watch for some "trigger" that changes how the f-keys operate. I have done this in the past, using either the volume keys, or the brightness setting keys - just to press those occasionally (maybe immediately after launching some app) to check that those still work.

DOS? What software are you using to run DOS? Parallels? VMWare? Something else? I would expect that any of those (which provide a means to run alternate operating systems) would be an easy possibility of modifying the keyboard mapping, at least while that software is running.
 

jasonmehmel

Registered
Restarting does get rid of the problem, temporarily.

I honestly can't think of anything I've installed recently, or even updated. I do test the keys occasionally, as you say.

For DOS, I use Boxer, which is a GUI for DOSBOX... basically to play old DOS games. Again, though, I haven't updated that program in years and this problem is recent.

I was hoping that maybe there's a log file to check or a diagnostic to perform.
 
Top