iphoto 5 problems

jole

Registered
i've hunted around for solutions to my iphoto problems, and none of what i've found has solved the problem.

when i launch iphoto (even if i hold down cmd + opt + shift) it gives me the "loading photos..." with the spinning loading wheel. forever. i didn't have that many photos to begin with, so it shouldn't be taking this long.

i'm using tiger, which doesn't include iphoto. so i had to reinstall it from my panther install disc. but now iphoto does this silly loading photos routine, and what's more, it cannot be updated with the software updater. it says there is no eligible iphoto application to be found in the applications folder. it's there, though.

what the heck ?

i've tried all the dummy solutions, like trashing preferences, moving my folders out of iphoto library, etc etc. nothing seems to get iphoto to run properly. i even tried deleting all the files and folders containing "iphoto" in the filename, and then doing a fresh reinstall from the panther disc. somehow i think this is the problem in some weird way.

has anyone else ever been through this ?

+
 

bobw

The Late: SuperMacMod
Launch iPhoto while holding down the shift-option keys. The shift-option key combination on launch causes iPhoto to ask if you wish to rebuild the library.

====================================

Move your iPhoto Library to the Pictures folder in your Home folder
- Delete the 4 data files in the iPhoto Library:

o AlbumData.xml
o Library.data
o Dir.data
o Library.cache

- Launch iPhoto with the shift-option keys held down
- This will cause iPhoto to prompt you for the Library's location and ask if you wish to rebuild the iPhoto database
 

jole

Registered
hi guys,

thanks for the suggestions. i tried everything you suggested, still no luck. i think the key to the problem lies somewhere in the fact that the software updater thinks iphoto is not an eligible iphoto application for the iphoto 5.0.2 update. makes me wonder...

+
 

jole

Registered
i keep fiddling with iphoto, deleting prefs, libraries, starting from scratch, fixing permissions, bla bla bla. still not working ! really frustrating.

any suggestions about how i can totally fool my computer into thinking iphoto has never been installed before, would be helpful...

+
 

bobw

The Late: SuperMacMod
Look here

Library>Receipts

If iPhoto receipt is there, move it out to your Desktop.
 

jole

Registered
iphoto is currently in /applications - its default install location. when i was running panther, however, i had made a folder /applications/applecations and stuck all apple related applications in there. it ran just fine from that spot.

and no, there was no iphoto receipt in the /library/receipts folder.

+
 

aicul

Registered
A silly question, but are you sure that the iPhoto of your Panther install disk is part of iLife'05 (and NOT iLife'04)? This could explain the refusal to update to iPhoto 5.0.2. Check the iPhoto about entry just to make sure.
 

MaddMan

Registered
I am having a similar problem with iPhoto 5.0. The opening screen appears with the whirling "loading photo" message, and then bombs to "The application iPhoto quit unexpectedly", with choices to close, report or reopen. "Try Again" repeats the above.

I have been using iPhoto in Tiger until this sudden onset. I have tried reloading the app from the iLife '05 dvd. Still no luck.

Open for suggestions.
 

MaddMan

Registered
In regard to iPhoto '05 failure to open, I found a reference from Google suggesting opening the app in Terminal. I tried (by typing in /Applications/iPhoto.app/Contents/MacOS/iPhoto). The app tried to open and failed. An error message appeared on the next line in Terminal: Segmentation fault.

Can someone interpret what that means?
 
Top