iPhoto inoperable after import


My older version of iPhoto (eMac 10.3.4) was disabled after importing some pictures originally edited in iPhoto '05. How can I resume working in iPhoto again?

Can you be a lot more specific about what the problem is? Is iPhoto refusing to launch? Does iPhoto launch but not let you edit those photos? Does it give you any warning messages? How did you import the photos -- drag and drop or via the "Import" command? Did you import the entire library, or just a few individual photos? What exact version of iPhoto was the "old" version (4?) and what is the new version (5?)?

Do you have both iPhoto 4 and 5 on your machine, did you upgrade to iPhoto 5, or did someone else do the editing in iPhoto 5 and now your version of iPhoto won't recognize those photos?

I'm not quite understanding what the problem is...
I have a Powerbook 12 (10.3.4) with iPhoto 05. I wanted to copy some pictures to my father-in-laws eMac (10.3.4) running iPhoto 04 (or whatever the previous version of iPhoto). Using my Powerbook with iPhoto 05, I used the export feature to save a bunch of pictures to a CD. I took the CD to my father-in-laws house, copied the CD files to the eMac hard drive, and then opened iPhoto (older version) and tried to use the "import" command to import them to the library. This operation failed.

Not only did this operation fail, but it disabled iPhoto completely!!!

When I try to start iPhoto on my father-in-laws eMac, I get an error message that says something like, "You imported photos from a newer version of iPhoto. Please upgrade this version." Then iPhoto quits. It refuses to launch!

I never even get to open iPhoto!!! :mad:
Ah... iPhoto 5's database is incompatible with iPhoto 4, and it sounds like when you imported the photos with iPhoto 4 it overwrote (or "updated") it's own database to the new version. If this is what happened, I don't know of a good way to "roll back" the database to the older version...

If there are no photos in the old iPhoto 4 library that you wish to keep, you can simply delete the iPhoto index file in ~/Pictures/iPhoto Library. Then, try dragging-and-dropping the photos into the iPhoto 4 library, which should cause it to rebuild the database in it's own format.

You might want to make a backup of the iPhoto Library folder before you try this just in case you'd like to be able to salvage any photos already in iPhoto 4 when you tried the import.

Just guessing, though -- that's what it sounds like to me.