Itunes Quits Post-license On Alternate Users


Ben R.
I was showing the Mac OS to a friend, for whom I had created a new user for the duration of the experience. We had occasion to pop in a CD on my PowerBook G4 and iTunes started as expected. Not having been opened before for this user, it displayed the license agreement first. After I clicked Agree, iTunes immediately quit.

This quit didn't qualify to the system as a crash, as it didn't display the application crash dialog. iTunes just sort of disappeared. I couldn't get it to run in this or a second alternate user, though it continues to work fine under my main user.

I tried quitting iTunes on the main end and it still didn't work. I tried reinstalling, logging out, and restarting, but nothing helped. Outside of a couple errors loading the DivX 5 and LiveType components of QuickTime, only three lines appear in Console when I try to open iTunes:

iTunes(24441,0xa000ef98) malloc: *** vm_allocate(size=3882397696) failed (error code=3)
iTunes(24441,0xa000ef98) malloc: *** error: can't allocate region
iTunes(24441,0xa000ef98) malloc: *** set a breakpoint in szone_error to debug

(If I remove the two problematic components, iTunes still quits in the same place and produces this log.)

I wish i knew where iTunes stores a designation that I've agreed to the license. It doesn't seem to be in preferences, which I've copied from the working user. Don't know if this would help anyway. Ideas?

- Ben
iTunes works on the alternative users, but not on the main administrative
user. On the administrative user, an attempt to use iTunes results in
the appearence of the Lisence agreement. When I agree, I get a popup
which tells me that I do not have sufficient privileges to open itunes.

I am not sure what is going on. however, you have to realize something about Mac OS X permissions. The application itunes music Library probably appears in YOUR user account (~/Music/iTunes/iTunes Music) only. Other users do not have privileges to look at your music! This Apple Knowledge document will help you. Also try logging into the new User account and deleting the preference file ~/Library/Preferences/ . Then run iTunes again, this may help.
Dear Satcomer,

Thanks for your post. I investigated the permissions.
This is what I found:

I have no file: dangottlieb/Library/Preferences/
where dangottlieb is my administrative account.

On my other standard account dhg , which I created recently to test the
iTunes problem I have:


and when I ls -Flas it I get:

2 -rw------- 1 dhg dhg 34170 Jan 6 13:32

On my wife's account, judyschaper which is quite old I have:


and ls -Flas of the file gives me

48 -rw------- 1 judyscha staff 22980 Jan 5 07:19

Now contrary to cflecs's post: "Also, you cannot have itunes open in 2 accounts at the same time.", right nowI have iTunes running on both dhg and judyschaper, both of which are standard accounts. My administrative account, dangottlieb, cannot open iTunes and just gets the license agreement and then the popup saying there are not enough access privileges to open it.

about a year ago, I was plying around with haveing different accounts and
the fast switcher, and I thought I had ruined my Mac. I had made dhg a
second administrative account. I eventually made a .dmg out of dhg and
somehow things got back to normal. Maybe this iTunes problem is related to that earlier event?

I feel very nervous changing permissions, since I can't predict what will