Launching the finder...

synaptojanin

Registered
OK, here is something really bizarre. I read somewhere else (macintouch, I think?) about a user who tried launching the finder (from his OS 9) folder.

Alas, when you double click the "Finder", classic launches. Sometimes, you can actually use the finder and browse your files.

Most the time what happens for me though, is that Classic crashes. At leasst, its icon is romved from the Dock. Nonetheless, I can continue to launch classic Apps. The process viewer reveals that TruBlue is running still...

...plus a bunch of other things that I am not sure what they are...

Sorry to be so vague, just ran into this and want to check it out some more.
 

synaptojanin

Registered
Before you go running and trying this, I would advise you to hold off.

In my hands it makes the system EXTREMELY unstable...

I'm looking into right now...
 

synaptojanin

Registered
Okay, this is extremely strange. I'll just post some screen shots so you can see for yourself.

First, <a href="http://toddot.net/osx/1.jpg">here</a> is a screen shot showing your typical situation. Classic was launched by double clicking a classic application icon - in this case, disk tracker. Note in this screenshot a disk tracker window and the process viewer. Classic shows up in the process viewer under the user processes. BTW - what is the 'pbs' process??

Situation 2: <a href="http://toddot.net/osx/2.jpg">here</a> is a screen shot where I double clicked on the Finder. Next, I launced disk tracker again. Check out the application list - NO CLASSIC. Also note the appearance of the Classic Finder. In the process viewer, again no classic, but the trublue environment is running. Puzzling.

What's more, sometimes when I try this, the classic finder launches allowing me to navigate through the file tree. Like others have noted before, the application menu in the classic finder reflects all processes, not just those running in the classic environment.

HUGE WARNING: this makes the machine unstable. It doesn't really crash, but hangs on restarting / logout. Restarting breaks the system, so that it boots into OS9. Hoever, I am able to boot back into OS X using the systems disk.
 

endian

Dis Member
to make a long story short, i tried this and ended up losing command line access (shells wouldnt execute, terminal.app reports [process complete] on startup)
 

Ghoser777

Registered
I don't know what's wrong with the rest of your guys computers (I'm guessing my 333 Imac is just superior :)), but double clicking on the finder works great on my computer. I even put an alias to it in OS9 startup items so it automatically runs everytime Classic boots up.

One thing I did do was try one of the first supposed fixes to the missing finder, but it seemed to mess everything up... but, when I deleted my Classic Support file, and then booted classic, it recreated my classic support file. Since then, I've never had a problem with the finder.

Just my $0.02
 

macavenger

Registered
Originally posted by Ghoser777
I don't know what's wrong with the rest of your guys computers (I'm guessing my 333 Imac is just superior :)),
Um.. Nope ;-) I also have a 333 Mhz. Imac, and I ran into the [Command Completed] problem after trying this trick. Oddly enough, defraging my drive with Norton Speed disk 6.0 beta appeared to fix the problem. Earlier versions of speed disk crashed when I tried to defrag using them, even though no version of Norton utilities reported problems after the first repair run. Oh well, as long as it works.
 
Top