login as root user, how?

terminal: sudo passwd

from there you'll be fine, basically. unless you screw up as root.
First of all, you'll have to enable the root user. This is done in NetInfo Manager. (You have to be logged in as a admin to do this, I think).

1. Select the menu Domain/Security/Authenticate, and type in the admins password.
2. Select Domain/Security/Enable Root User. I think you will be asked to enter the root password here.

Then you'll have to change the login window, so you will be able to enter a user that's not in the list. (We're talking 10.1 here, in 10.0.x you don't have to do this). There's two ways to do this, either check the "Show other users" option in the Login preference pane, or select to display the login window as "Name and password entry fields".

I think that's all. Now you'll be able to log in to Aqua aswell as Darwin as root.
You can enablke login as root by running the netinfo manager. This is kept in the Applications/utilities directory. From the dirctory menu ( once started) highlight securty, and select "enable root user".

This will allow shell login to root as well.

After saying this, I have not found a requirement for it. As the previous poster said, using su from a terminal session should suffice. If you ever need to install software that needs special access it will ask you for your install password which will essentially give you root acess for the duration of the install
In terminal just type "sudo passwd root" (without quotes). Enter your admin password, then enter and verify root password. Root is now enabled. That's actually how I usually do it.
As usual the level of knowledge in this group is outstanding.

Thanks for all the replies

I logged in at root level in no time and was able to delete "deleted Users" that were left behind from experimenting with ftp login names

Thanks Again

I am running 10.5.2 and I was looking for "Netinfo Manager" and I could not find it. Granted I am new to the mac. However I used the sudo command to change the password for root. Once that was done, I was able to do an "su" to the root sign-on. I needed access to root to add hosts to the '/etc/hosts' file as I have a couple of boxes running Linux at home.
I followed the link and did clicked on the "Lock". It already had my user id so I typed in my password. The lock opened up. The next instruction was to enable "Root login", however there was nothing on the screen that mentioned anything to that effect. Am I missing something?
You should see this: