Lost audio: keyboard keys display no entry sign, all other vol options greyed out

jumu

Registered
Hello,

This is my first post as I've joined this because I desperately need some help from some experts.

I went to play some music from my mac os x - v.10.6.8 yesterday, to find that the volume controls are inactive: I use the internal speakers and have nothing else plugged in.

I've read other posts and followed their suggestions, so far I've tried:

Switching off and pressing command + alt (options) + P + R at the same time before the grey screen comes on (I do not hear the startup noise) and nothing appears to happen.

I've looked at Audio MIDI Setup but 'output' is greyed out and therefore inactive.

I've been to Activity Monitor and 'Quit' coreaudio and again no change.

In System Preferences - 'Output' has no option to switch to internal speakers. Only device for sound output is 'Name: Digital Out / Type: Optical digital-out port'

Does anyone else have any other suggestions it would be greatly appreciated.

Many thanks
Jumu
 

Cheryl

Rosie Moderator
Staff member
Mod
Check Universal Access. You might have turned it on, disabling sound.
 

DeltaMac

Tech
I think more likely, is that the output port is stuck.

Look inside the output port. Do you see a red light?
Red light indicates that the Optical (digital) output is selected, and would be the reason that the volume doesn't seem to work.
If so, try inserting headphones, or external speakers, etc.
Sometimes a headphone plug will incorrectly turn on the optical (digital), and inserting, then removing that plug a few times may reset the internal connector. The red light should go out, and your Sound pref pane should then show that you have internal speakers (and all should be well with the world. :) )
 

jumu

Registered
DeltaMac you're a genius, thank you so much, your suggestion worked a treat.

Let the tunes play.

Thanks again
Jumu.
 
Top