Macbook & 1TB HD

killerinc

Registered
Hello i am working on a Macbook A1181 13" White Laptop.

I tried two of the exact same drives and still i cant get a 1 tb Western Digital 9.5mm drives brand new drives to install the original OS X Disks. Held down C and tried to install OS X on it and no drive showed up then ran Disk Utility and it showed as a 7.3 Tb drive. Tried to Erase got the Disk Erase Failed ... Input/Output Error. Then tried to partition and got the same error.

I am a repair tech and have done this many times but cant figure this one out.

500 gb is the biggest drive i can get to work properly but the drive is full and needs a bigger drive.

Has anyone figured this out cuz it cant be 2 bad drives and it seems like a drive limit issue. Read somewhere else that someone has the same issue but with a 640 GB Drive that reads as a 5.5 Tb.
Is 500gb the biggest that will work?
Thanks.
 

killerinc

Registered
Yeah thats what is baffling cuz it should be fine. One thing though is that if i put back the 500gb or put in a brand new 500gb it works fine. Why anything over 500 gb wont work is a mystery.
 

djackmac

ACMT
I've seen the same issue a few times recently with those old 10.4.x OEM Intel installers and newer drives. Use a retail 10.5.x or 10.6.x installer and everything will work fine. Maybe something with the firmware on these newer drives that don't mesh with the installers code.
 

killerinc

Registered
Thx i will try that DJ.
Update.... I purchased a new 500gb which what was in there and it read during the installation 3.3tb . So i think it might be an issue with the controller on the motherboard. It's reads the all the drives but at a higher capacity. But still cant install OS X
 

djackmac

ACMT
Thx i will try that DJ.
Update.... I purchased a new 500gb which what was in there and it read during the installation 3.3tb . So i think it might be an issue with the controller on the motherboard. It's reads the all the drives but at a higher capacity. But still cant install OS X
What part of use a retail 10.5.x or 10.6.x installer do you not understand? That's all it takes. There is no "issue" besides those installers don't work with the newer firmware on these drives.
 

killerinc

Registered
I know, i was going to try it when i get home, but when i told you about the 500gb update that was something i did before i read your post.
On a side note the original 500gb has bad blocks and wont boot and Lost data. Can u recommend any programs that can help recover the data.
I have used in the past DiskWarrior, but it's not helping in this case.
 

DeltaMac

Tech
Disk Drill looks to be a good recovery product.
or
Stellar Phoenix Mac Data Recovery
or
Prosoft Data Rescue 3


If you don't have any great success with software, then there's always a commercial data recovery service, such as DriveSavers
Be prepared with a large chunk of money for that...
 

djackmac

ACMT
Make a clone or disk image with Data Rescue III. If the drive does not mount, clone it to another drive with DRIII. Then straighten out the drive you cloned to with Disk Warrior. If the drive does mount, make a disk image with data rescue III and make sure the disk image mounts afterward.
 
Top