Macbook not connecting to Netgear WGR614 wireless.

ShiroMuta

Registered
OK, here's the issue.

New Macbook, Core2duo, running OSX, 10.6.8

Netgear WirelessG router WGR614V9 Running B and G, and using WPA2 auth.

The Macbook can see the wireless network. It can try to connect, but regardless of authentication level (either WPA, WEP (ugh) or unprotected) it cannot connect. It gets a connection failed message when it does try.

The router is fine, and it has other devices connected to it. The Macbook is fine as it has connected to other networks.

I've tried the $ trick as well as putting quotes around the passphrase.

I've yet to see anything else where someone has posted a decent fix.

Just throwing it out there.

FYI, the ISP we're using is Time Warner Cable in the US.
 

Satcomer

In Geostationary Orbit
Once you think the Mac is "connected" open System Preferences->Network pane, and see if it sees it there. If it has a green dot and is getting an IP from the router. Highlight the Airport card and in the righthand part of the pane and select the "Advanced" button. In the drop-down click on the DNS tab and see if you getting a DNS address.

I suggest you use either OpenDNS (they have an instructional video) and use that. Also you could use Google's Public DNS if you use a lot of Google services.
 

ShiroMuta

Registered
Whoops, slight misunderstanding here. There is no connection being made. I get the router in my airport list, but when I click on it to connect it doesn't make the connection. As such, it doesn't show up in my Network pane.

When I set the router to WEP or WPA authentication, the Macbook actually does ask for the passphrase and can even detect the proper auth scheme (I.E. if I set the router to ask for WEP the Macbook asks for a WEP password. If I set the router to WPA, the Macbook asks for a WPA password). It just doesn't seem to be able to negotiate the connection past that point. As soon as I type the password and click OK, the Mac responds with a Connection Failed message.
 

ShiroMuta

Registered
Yep, restarted the router. All my other wireless devices are connecting without issues, it's just the Mac that can't make connections.
 

Satcomer

In Geostationary Orbit
Did you reset your Airport connection?

1. Reset Your PRAM to see if that helps.

2. Try the fixes in the blog post How I fixed my dropping wireless Airport connection problem in Snow Leopard

3. Open System Preferences->Network pane and at the top of the Network pane is "Location". Use the "Location" drop-down to create and new, Custom Named, Location and click on the 'Apply' button to save your new Location. Then after you save try to join your wireless network.

Lastly consider getting a modern wireless router that does wireless N and wireless G, B signal separately (at the same time, some even have a "guest" wireless network).
 
Last edited:

ShiroMuta

Registered
That one did it. Zapping the PRAM and then changing the channel for my router seems to have done the trick.

Thanks a ton for all your advice. Sorry for being such a Mac Noob.
 

Joe Castellon

Registered
Was having the same exact issue with this router and a MacBook Pro 13 2015 edition.

The strange thing is that the router is more than 4 years old and my MacBook had been working just fine with it for over 9 months.

I already had my workaround which consisted of the following steps:
  1. Turn off WiFi
  2. Delete the following files:
    /Library/Preferences/SystemConfiguration/

    com.apple.airport.preferences.plist

    com.apple.network.identification.plist
    com.apple.wifi.message-tracer.plist
    NetworkInterfaces.plist
    preferences.plist
  3. Shut down the MacBook and unplug the MagSafe adapter
  4. Reset SMC
  5. Reset PRAM
Soon enough I realized that these steps provided a temporary fix, and sometimes would require 2 or 3 tries.

After reading this thread I tried changing the channel to 11 and the mode to "g only". So far this has provided the most stability and I haven't had the network fail on my MacBook.

It's probably just a coincidence (I hope) but these problems with my MacBook began shortly after setting up my Apple TV 4th Gen. Just like the OP though, my issues have been exclusive to the MacBook.

Ps. Sorry for reviving this thread. I wanted to say thanks for helping me find a fix to my WiFi issues. :)
 
Last edited:
Top