Mavericks, Apache and 403 Forbidden

bunner bob

Registered
I'm setting up a colleague's new MBP running Mavericks and having a hard time getting the webserver working properly.

Following various posts elsewhere I got MySQL installed and running, enabled PHP in httpd.conf, allowed access by "all" in that file as well, but when I created a phpinfo.php file in /Library/WebServer/Documents I got a 403 Forbidden. Tried all sorts of permission settings and I think I've broken something, because now even the default index page (http://localhost) is giving me a 403 Forbidden.

I repaired permissions and ran ACLr8 to clear up the ACLs that were created with my messing about - I'm as close to "stock" as I can figure out, but I'm missing something.

Permissions/owner for WebServer and Documents are now rwxr-xr-x root wheel. Permissions for the default index file are rw-r--r-- root wheel.

Whether I hit http://localhost or http://localhost/index.html.en I get a 403 Forbidden.

I'm hesitant to just keep thrashing around setting permissions. I believe it has something to do with Apache running as www or _www. I just want it to work like my own 10.7/Lion setup works. My WebServer has the same permissions/owner, and Documents is rwxrwxrwx, same owner.

What should I try next?
 

bunner bob

Registered
Just a note - ran ps aux | egrep '(apache|httpd)' to see what user Apache is running as. I got 4 lines of output - the first three with _www and the last with root.

If that helps any.
 

bunner bob

Registered
There are two commands in that post - I ran both of them (the first has a typo - it's root:wheel, not root.wheel). No effect.

Also looked at the log - nothing significant there.

The second post is for "updating to OS X Mavericks" - this is a new computer with Mavericks built-in. No pre-existing Apache install to copy from.
 
Top