MBP / External HD / Sleep related issue

soulartist

Registered
MacBook Pro, OS X Mountain Lion (10.8.2)

If I enable the external Western Digital My Passport firewire drive security, I can access my files on that drive.

But, when I put my MacBook pro to sleep then wake it up and try to access a file on the WD drive I get HD related errors such as #50 and #36, or the disk is write protected when I try to open an Adobe Premiere Pro file. I can't open a file or copy a file from that drive.

For some reason, I'm getting locked out after waking the computer.

I've spent hours on the phone with WD tech support. After going through their list of tests, they told me that they haven't encountered this issue—and that it seems to be a system sleep related problem.

If I disable WD security, then all is well. But, I want the security on for when I'm out with the drive.

Note: This same WD external firewire drive with WD security enabled works fine on my iMac / 10.6.8.

This apparent sleep / external drive issue appears to be peculiar to my MacBook Pro / 10.8.2

More testing:

1) Changing user has no effect.

2) Starting up in Safe mode has no effect. Issue persists.

3) Tried the USB cable, but no help

4) If I connect the WD drive (with WD security on and no related apps running) I can drag and drop a file onto the drive. After sleep, I can no longer drag and drop. Also, when I try to eject the drive, I get messages that it can't because one or more programs may be using—which is not the case.

Any suggestions to narrow down the culprit?
 

DeltaMac

Tech
Sounds like the WD security is not quite compatible with Mountain Lion.

You could leave the WD software off, and use your built-in FileVault 2 to encrypt that hard drive.
Don't know if that would work on older OS X versions (before Lion), however (I've never tried it)

If you have problems ejecting the drive - it's usually due to Spotlight automatically updating its database, which would be the software that is in use - nothing that you actually launched yourself.

Try to eject the drive a minute later. If it still complains, log out, then log back in, and you should be able to eject the drive immediately after you log in.

Have you tried running a Disk Repair - using your Disk Utility - on that WD hard drive?
Since Lion, the Repair Disk function will check different items, depending whether you select a drive's partition, or the line for the device (which has the manufacturer's info) before clicking the Repair Disk button.
 

soulartist

Registered
I don't think it's the drive, as it works with no issues on my iMac / 10.6.8.

Logging out and in doesn't work, either. I have to shut down.

With security off of the WD drive, I now noticed that Photoshop will not let me edit an image. Ejecting the WD lets PS work.

Is there a way to turn off Spotlight?
 

DeltaMac

Tech
I don't usually turn off Spotlight. I suggest that you can open your System Preferences/Spotlight pane. Click on the Privacy tab, and then add that external to the list of items. That will prevent Spotlight from searching that drive - and won't take over that drive.

You may have ownership issues on your WD drive, (particularly if you use it on several different Macs) which may be interfering with the Adobe files.
You could probably try getting info on your WD drive, and checking the box "ignore ownership on this volume"
You may need to click the padlock to unlock that setting.

And, you may find some good information in this article: http://reviews.cnet.com/8301-13727_...finder-requires-passwords-for-managing-files/
 

soulartist

Registered
I appreciate your suggestions, and I tried all of them. Unfortunately, they haven't resolved this nuisance issue.

I only tested WD drive on the iMac for check.

Photoshop is now working for whatever reason.

I don't get messages asking for permissions.
 

DeltaMac

Tech
I didn't say anything about permissions.

You did say that you were having problems editing photoshop files. If those files are on the WD drive, and you don't "own" the files, or the folder where those files are located, that can give you strange issues with photoshop.

Test Your Hard Drive on the Mac that's running 10.8.2, as that's the system where you are having problems - correct?

I would be most concerned with the error -36 that you mentioned. That's an I/O error (bummers), and very often means that the hard drive is failing. At the very least, you should back up the data on that hard drive, and reformat.

The I/O error seems more common with a network-connected hard drive.
Is yours connected through a network - or a local drive through USB?
 

soulartist

Registered
Photoshop is working now. Files were not on WD Drive, which contains 3 partitions. I tried having only one partition but that made no difference.

Firewire connection. I also tried the USB cable for the WD with no help. Yes. I do have a backup.

Disk utility and Disk Warrior both report that the HD with the system is okay.

I was told that the internal HD is new. A recently formatted the disk, did a clean install of ML, and then migrated files from my iMac.

All other functions seem to work. It's the WD security that's in conflict with something after I awake the computer from sleep. I had thought safe mode would resolve the issue, but it persisted there as well.

I reset the SMC but no help there, either. It's another peculiar problem.
 

DeltaMac

Tech
New hard drives also may fail. That's one of the reasons you have a warranty.
However, judging by your description, I still suspect that the WD security software is the primary possibility.
If you can eliminate your problem by leaving that WD security off, then that's a good fix.
If you still want to protect the data on the drive, then you'll need to go to a different option to secure the hard drive, such as filevault, or another software solution - or even something as simple as locking it in a desk when you are away.
 

soulartist

Registered
I did look at filevault but I didn't see a way to select the WD drive.

For now, I'm leaving WD security off. Maybe a solution will arise.

BTW: I did read in few forums that a number of people with MBPros are having external drive issues (although not the same as mine) using ML.
 
Top