Mentor Router Refusing to Port Forward


Wishful Drinking
Hi all,

I've got a network here which is connected to the internet through a Mentor router - not sure which model exactly, but the control panel matches pics I've seen for the Annex-A-V3.27.

My problem is this - I have a Mac Mini on the network that I have set up as a web/ftp server. Since this is on the LAN side of the router, I have enabled Port Forwarding under the "Virtual Server" bit of the router menus and have forwarded the relevant ports (20, 21, 80, 81) all as TCP (not UDP) to the Mini's network address (

If I try to access the FTP site or web pages on the Mini from any other computer on the network, everything works perfectly so I'm guessing I've set that bit up right. However, when I try connect to the server through the proper IP address that the router has, it doesn't seem to want to forward the request on to the Mini. When I FTP to that address, I just get a login failed, and if I stick the address in a web browser, even with :80 or :81 after it, I get presented with the admin login screen for the router.

I've read somewhere that the router had issues with port forwarding using NAPT so I have set it to Dynamic NAT and it still doesn't work. I've also tried setting up NAT sessions and making everything accessible and inaccessible from WAN and LAN - no combination of settings seems to do the trick and I'm losing the will to live!

Can anyone suggest something that might work. The pages at just say "HTTP requires you to forward the 80 ports. Go ahead and enter the settings shown above into the Virtual Server Configuration menu and then click Add This Setting. When you're finished, click Save Settings near the left side of the screen to save your changes.
And that's it! You're done!", but I've saved them and no, that's not it!

And yes, I am saving the configuration changes and even rebooting the router between each set of changes. There don't seem to be any settings for Port Triggering if I need that.


Wishful Drinking
Sussed it - tried from home and it works perfectly when you're outside the network! Bleedin' thing...


In Geostationary Orbit
Pony up and get a new router dude. You will probably benefit from faster built in ports (if your router is a couple of years old).


Wishful Drinking
Not mine - it's a work one so if it works, it works. The rest of the network is fine and gigabit, just the internet link that's below par. I think much of that is down to the ISP tho.


Staff member
Ehrm, I'd say it works as intended, then... Where's the problem? Internally, it works with the internal IPs, and from outside, it works with the outside IP. Port forwarding's obviously working.


Wishful Drinking
Yeah, I said that in my second post! I was thrown by the fact that the outside IP didn't work from inside, clever as I was being. Cheers, all!