Messenger for Mac Error After Sign-in.

Reeny

Registered
Hello. I am new here and I hope this is in the correct location. Hopefully someone can provide a solution to this problem. Recently, my Messenger for Mac 7, which I installed over a year ago, has not been letting me log in. I was receiving an error that said: 'Sign in to MSN Messenger failed because the service is not available to you or you may not be connected to the internet.' I scoured the internet for answers and found that clearing the account history worked for me.

Now I can sign in, only problem is that every time I sign in, it crashes after a few seconds, says an error has occurred and quits. I have been searching over the few days for a solution and have yet to find one that doesn't involve switching to Adium or aMSN, which I would prefer to avoid if at all possible.

I'm going to include the error report, just in case it helps.

Microsoft Error Reporting log version: 2.0

Error Signature:
Exception: EXC_ARITHMETIC
Date/Time: 2010-10-23 19:26:52 -0600
Application Name: Microsoft Messenger
Application Bundle ID: com.microsoft.Messenger
Application Signature: MSNS
Application Version: 7.0.0.080409
Crashed Module Name: Microsoft Messenger
Crashed Module Version: 7.0.0.080409
Crashed Module Offset: 0x0001fea7
Blame Module Name: Microsoft Messenger
Blame Module Version: 7.0.0.080409
Blame Module Offset: 0x0001fea7
Application LCID: 1033
Extra app info: Reg=English Loc=0x0409

Thread 0 crashed:

# 1 0x00020ea7 in __mh_execute_header + 0x0001FEA7 (Microsoft Messenger + 0x0001fea7)
# 2 0x000229a2 in __mh_execute_header + 0x000219A2 (Microsoft Messenger + 0x000219a2)
# 3 0x0005d263 in __mh_execute_header + 0x0005C263 (Microsoft Messenger + 0x0005c263)
# 4 0x0005d382 in __mh_execute_header + 0x0005C382 (Microsoft Messenger + 0x0005c382)
# 5 0x0013bf06 in __mh_execute_header + 0x0013AF06 (Microsoft Messenger + 0x0013af06)
# 6 0x000c6bf5 in __mh_execute_header + 0x000C5BF5 (Microsoft Messenger + 0x000c5bf5)
# 7 0x96d8f11d in .objc_class_name_IPMDFontRange + 0x96A644DD (HIToolbox + 0x0000811d)
# 8 0x96d8e55b in .objc_class_name_IPMDFontRange + 0x96A6391B (HIToolbox + 0x0000755b)
# 9 0x96d8e3c0 in .objc_class_name_IPMDFontRange + 0x96A63780 (HIToolbox + 0x000073c0)
# 10 0x96dbcd34 in .objc_class_name_IPMDFontRange + 0x96A920F4 (HIToolbox + 0x00035d34)
# 11 0x96d8f4d6 in .objc_class_name_IPMDFontRange + 0x96A64896 (HIToolbox + 0x000084d6)
# 12 0x96d8e55b in .objc_class_name_IPMDFontRange + 0x96A6391B (HIToolbox + 0x0000755b)
# 13 0x96daaeac in .objc_class_name_IPMDFontRange + 0x96A8026C (HIToolbox + 0x00023eac)
# 14 0x000e8709 in __mh_execute_header + 0x000E7709 (Microsoft Messenger + 0x000e7709)
# 15 0x96d8f11d in .objc_class_name_IPMDFontRange + 0x96A644DD (HIToolbox + 0x0000811d)
# 16 0x96d8e55b in .objc_class_name_IPMDFontRange + 0x96A6391B (HIToolbox + 0x0000755b)
# 17 0x96d8e3c0 in .objc_class_name_IPMDFontRange + 0x96A63780 (HIToolbox + 0x000073c0)
# 18 0x96dbcd34 in .objc_class_name_IPMDFontRange + 0x96A920F4 (HIToolbox + 0x00035d34)
# 19 0x96d8f4d6 in .objc_class_name_IPMDFontRange + 0x96A64896 (HIToolbox + 0x000084d6)
# 20 0x96d8e55b in .objc_class_name_IPMDFontRange + 0x96A6391B (HIToolbox + 0x0000755b)
# 21 0x96daaeac in .objc_class_name_IPMDFontRange + 0x96A8026C (HIToolbox + 0x00023eac)
# 22 0x96e17a4c in .objc_class_name_IPMDFontRange + 0x96AECE0C (HIToolbox + 0x00090a4c)
# 23 0x96e142a2 in .objc_class_name_IPMDFontRange + 0x96AE9662 (HIToolbox + 0x0008d2a2)
# 24 0x000e8878 in __mh_execute_header + 0x000E7878 (Microsoft Messenger + 0x000e7878)
# 25 0x00064f5a in __mh_execute_header + 0x00063F5A (Microsoft Messenger + 0x00063f5a)
# 26 0x00064fec in __mh_execute_header + 0x00063FEC (Microsoft Messenger + 0x00063fec)
# 27 0x0000261e in __mh_execute_header + 0x0000161E (Microsoft Messenger + 0x0000161e)
# 28 0x00002545 in __mh_execute_header + 0x00001545 (Microsoft Messenger + 0x00001545)

X86 Thread State:
eax: 0x56d9104a ebx: 0x56d9104a ecx: 0x00000000 edx:0x00000000
edi: 0xbfffd

Any solutions are greatly appreciated!!
 

DeltaMac

Tech
Here's a thread with a variety of possible fixes.
Have you tried deleting the .plist file for Messenger?
should be the file named "com.microsoft.Messenger.plist" in your user/Library/Preferences folder. The next time you launch Messenger, it will ask for your sign-in credentials, then you should be good to go.
 

Reeny

Registered
I tried deleting the .plist file and went through the set up again, but it didn't fix the problem. I'm still getting the error coming up right after I successfully sign in, and then it crashes.

Thank you though for the suggestion.
 

DeltaMac

Tech
I missed posting the thread with other possibilities, and now I can't find it :)
You can try updating your Messenger app, your version 7.0.0 has been updated to 7.0.2, and theres'a beta for version 8.
In my experience, Messenger for Mac is just not too stable, and others use alternates, such as aMSN, with better luck. Here's a page where you can download either the current version, or the beta of version 8: http://www.microsoft.com/mac/downloads.mspx?pid=Mactopia_Messenger#viewer
 

Reeny

Registered
I downloaded the 7.0.2 update and it seems to be working fine at the moment. Thank you VERY much!!

Problem solved!!! :D
 

JeffCGD

Registered
New version is out: Version 8 is available from MIcrosoft and is a notable improvement over previous version.
 
Top