Missing Sound Fix???

Talikan

Registered
This topic has been brought up before but I would like to reiterate it. OS X does not put out sound, any sound, in several cases. I have heard of this happening on iMacs, Beige G3's(which I have) and with Powerbooks.

I have a:
PowerMac G3(Beige) 300/192Ram/12GB
ATI Nexus 128
External Speakers(sound jack)

One person fixed this problem by rewriting the audio drivers, but that was on a 7200.(Amazingly) Other fixes were turning mute on then off in control panel and using internal speakers only. Anyone got another fix? Apple engineers???
 

LunaMorena

Registered
For my iMac, the internal speakers work no problem if I don't have anything else connected, but they don't sound very good. The externals either work if they're connected to one of the headphone jacks in front or if they're on the standard speaker out port on the side and then I plug something else into the headphone jack after the system starts up. This has been fairly consistant for me, but I don't know what works for other systems.
 

Talikan

Registered
That is a valid fix for iMacs, but unfortunately, PowerMacs only have one audio out port and even the internal speakers don't work. I have a feeling that this must be a driver problem for the audio out port on certain motherboards.
 

tobey

Registered
If your machine uses the 'awacs' sound chipset, you can enable sound. I know this chipset is used in the 7500 class machines, and I think others too.

To enable the driver for awacs, you have to edit something like:

/System/Library/Extensions/AppleAudioScreamer.kext/Info.plist

(That name / path is from memory, and I'd be very surprised if it's 100% correct. It should be enough to get you to the right file though!)

Edit this file. There should be a line similar to:
&ltstring&gtdavbus&lt/string&gt

ADD this line below the davbus line:
&ltstring&gtawacs&lt/string&gt

And then reboot. ...I'm sure you can make this take effect without a reboot, but I'm not sure how.

Enjoy, ...and I hope I'm not too far off topic.
Tobey
 

Talikan

Registered
There is no Info.plist in the AppleScreamerAudio folder, but there is a file named Info-macos.xml and another named AppleScreamerAudio. You can open the Apple ScreamerAudio in Textedit, but there is no such string in that file, and you can't open the xml file. Whats the fix?
 

Torch'em

Registered
If you think that that is bad, consider this:
While my OS 9 drive was apparently corrupt(I now suspect QT 5 had a role in this), I couldn't get sound in OS 9. I'm still trying to figure out what happened. Any ideas? My symptoms were:
No sound
Files that were apparently 'in use'
Computer forgot which drive to start up from
Problem stopped after I uninstalled QT5, but started after I configured Apache under OS X
-I know that it sounds a little like a battery problem, but MY G3 400 is less than 2 years old and it is on about 99% of the time.
 

AdmiralAK

Simply Daemonic
I seem to have not prob :)
I have connected my sound out to my myni stereo system with a headphone jack to RCA cable ;) it rOx :)
** Although my Music Player does sound choppy from time to time but that probably has nothing to do with it :) **
 

shifter

Registered
You are right. There is no Info.plist.
You have to open:
/System/Library/Extensions/AppleAudioScreamer.kext/Info-macos.xml

Do a search for "davbus".
Replace it with "awacs".

That will fix the problem IF the chipset on the machine in question is indeed AWACS.
It worked on a 8500 with a G3 upgrade.

Kirk

Originally posted by Talikan
There is no Info.plist in the AppleScreamerAudio folder, but there is a file named Info-macos.xml and another named AppleScreamerAudio. You can open the Apple ScreamerAudio in Textedit, but there is no such string in that file, and you can't open the xml file. Whats the fix?
 

shifter

Registered
TextEdit works just fine.
Drag the icon onto TextEdit in the Dock holding down option-command. This will open the file.
Make sure that it is saved as plain text.

Originally posted by Talikan
But how do you open the xml file? Using what app?
 
Top