Mountain Lion Screen Auto Brightness Issue


Staff member
Okay, this is really weird.

But since upgrading to Mountain Lion, my Thunderbold 27" display, hooked to my MacBook Pro 15" is constantly going up and down. As I type this it just reduced itself to almost the lowest setting and it will in a little bit get bright. Even if I set it to full brightness, within seconds it will start to lower itself. It doesn't always go down all the way, nor does it always go down. Sometimes it will get brighter.

I first noticed the issue when I was constantly having to (oh no I can't see what I' am typing, okay, just barely now, didn't know my screen could get this dim, lol) increase brightness numerous times, but seemed to be when I walked away.

Note: I have the morning sun shining directly on my MacBook Pro, but the lid is closed. The sun is rising and with different shadows perhaps the censor on the MacBook Pro is controlling the brightness.?? I guess I will put something in front of it to block the sun and see. Okay, I covered it with magazines so it should be nice and dark under that and no change in my display.

So I went ahead and increased the brightness to full brightness cause it wasn't changing and I could barely see.

Okay, I feel like an idiot but will post this anyway for others having same issue. This seems to be new on 10.8 but there is a option to automatically adjust screen brightness for the Thunderbolt display. Wow, that really doesn't work all that well. If it worked properly, I think it would be neat because getting up at 2am to fix an issue you get blinded by your display.

It's disabled and all seems well.


In Geostationary Orbit
The only thing I could suggest is going into Display and make the dimming screen the primary, for a minute or two. Then once it is the primary dive into System Preferences->Displays & System Preferences->Energy and make sure the settings are were you want. then you can switch the monitors back to the original positions and see if those changes stick.

This is only a suggestion since I don't use dual displays, so Good Luck.