Mouse under Mac OS X 10.1

PoweMACuser

Registered
The mouse sensitivity under Mac OS X 10.1 is not enough. I have to move a very long distance to move the point on the screen. I am using Logitech mouse. I don't know whether the mouse from Apple works well. I have set the sensitivity to the max and still the system track the mouse slow.

Any body come across this problem?
 

van6ogh

Registered
I also have this problem. Although I don't think it's an actual "Problem" as in a Bug, it's just the highest setting is too damn slow (for me anyway). I'm dying for an OS X version of USB Overdrive.... anyone hear anything on that?

jim
 

justinkim

Registered
If you have a Kensington mouse, try installing the Mouseworks beta available on Kensington's website.

I noticed that mouse acceleration wasn't all I wanted it to be before I installed it. Afterwards, my Kensington optical was plenty zippy. It also fixed the problem of the OS forgetting my mouse speed settings when I switched between computers on my KVM switch.
 

doppelbock

Registered
the kensington driver certainly solves the problem for those of us with their mice/trackballs....but still, apple should amend the mouse control panel to allow for more acceleration. it's just fine on a 15" monitor (800x600) but at higher resolutions it's way too slow....
 

~vert

It's short for vertigo...
Here is a tip by Darkstranger2 from another forum:

You need to edit the file /Users/your_name/Library/Preerences/.GlobalPreferences.plist. Once you have that file opened up, scroll down to where it says <key>com.apple.mouse.scaling</key> - under it will be a number, probably set at 1.7 (with a bunch of zeros after it). Set that number to whatever you want (be careful - I set mine to 5.2 and it's quite zippy, so don't go crazy and set it real high). Now to get the mouse to actually start moving faster, open up the mouse preferences in System Preferences but don't mess with the settings listed there. Just close it and you'll notice the mouse zipping by MUCH faster.

Just make sure not to adjust any settings in the mouse preferences, otherwise you'll have to do this all over again.

Just as a note - defaults won't let you change this setting, that's why I'm telling y'all to edit it by hand.

Feel free to pass this one on to any boards/lists/whatever you guys frequent. I think it's a rather good one!
I found that I needed to log out and log back in to see the change.
 

Darkshadow

wandering shadow
Um..that was my tip over at MacFixIt (where I'm Darkshadow2), not Darkstranger2's ;)

I also posted it here in the tips & tricks forum.

<i>I</i> still stand by the fact that you can just open up mouse preferences and close it then quit System Prefs, but maybe that doesn't work for everyone. Logging out and back in again will though.

Just so long as you don't change any of the preferences in mouse prefs, you won't have to worry 'bout it. :p
 

~vert

It's short for vertigo...
Mea culpa! Sorry about that. Darkstranger..., Darkshadow..., what's the dif?;)

At least I gave the credit to someone.

I did see that you had posted your tip after I had added it here. Didn't mean to double post. It's a great tip, though. Now I just need to be able to use the 3rd and 4th buttons on my Logitech MouseMan and I will be golden!!
 

sithious

no longer a member
hmmm... i don't have a globalpreferences.plist in my preferences folder ... strange. sure this applies to 10.1?
 

~vert

It's short for vertigo...
Yep, I'm using 10.1. The file is hidden so you will need an application that can either enable invisible files to "unhide" or an editor that can access hidden files.

I use TinkerTool 2 to enable access to hidden files. Then I just open it in TextEdit You can find TinkerTool on Version Tracker.

If this is not the reason for not finding the file, my only guess would be that it is created when you access the Mouse preference panel for the first time. Have you changed any mouse settings yet?
 

abdiel_bc

Registered
The tips posted by DarkShadow2 here and at MacFixIt are confirmed to work provided that you don't unplug/replug your mouse or use a KVM. If this is the case for any of you, you should edit the file at /Library/Preferences/.GlobalPreferences.plist (not the one in your home dir). This should set the global default to a more usable level. I've noticed that if I use my KVM switch, the mouse settings go back to the default sluggish pace. Note that you may have to create a key first in this file; it should read:

key com.apple.mouse.scaling /key
real your value here /real


Incidentally, the real value type is why you can't use the default command to make this setting.

Hope this helps!
 

abdiel_bc

Registered
UPDATE:
Carsten Klapp has actually created a faster mouse driver for USB mice (note: ADB mice not affected) that will help speed things up for you so you can still use your system prefs to slow things down if you need. The URL:
http://homepage.mac.com/carstenklapp/turbomouse/

This installs a small kernel extension at /System/Library/Extensions/AppleUSBMouse.kext that the system will look for by default at boot time to override the existing driver. He also gives some simple instructions on building your own mouse driver (I'm currently looking for one that won't lose my prefs every time I switch back to my OS X 10.1 box on my KVM--if anyone else has this problem, let me know and I'll give you a script to load and unload this particular kext file).
 
Top