Mutiple Problems With Updates And Printers…

phishyphood2600

Registered
I am running into some problems lately. It all started when I tried to print and it wouldn't let me, it gave me an error. So I tried to remove the printer from my list and re-add the printer and then I got this error:

An error occurred while trying to add the selected printers.
Error 20

After searching on the net for a solution with none that worked my system wanted to do a software update. So I let it run its course and this is what it tells me:

Make sure you have permission to write to /private/tmp/501/TemporaryItems/com.apple.SoftwareUpdate, then try again.

So I search and find others with the similar problem as I but not the same and try what has worked for them, but to no luck for me. Here is the type of computer I have:

OS 10.3.9
PowerBook G4 400MHz
786 MB SDRAM
10 gig hard drive with an external Lacie 120 gig

If you could please help me out that would be great, it sucks when you can't print and update your software. Other than that stuff it runs great.

Mike
 

barhar

Registered
With respect to the 'com.apple.SoftwareUpdate' file:
01. Click on the 'Desktop' to bring 'Finder' front most.
02. Select the 'Finder's 'Go, Go to Folder...' menu item.
03. Whether an individual 'Go to Folder' window appears, or a sheet appears from any existing folder's window, enter ...

/private/tmp/501/TemporaryItems/

... and click the 'Go' button.
04. The 'TemporaryItems' folder's window will appear. Locate and trash the 'com.apple.SoftwareUpdate.plist' file.

An alternative way is:
01. Launch 'Terminal' ('/Applications/Utilities' folder).
02. Enter ...

rm -rf /private/tmp/501/TemporaryItems/com.apple.SoftwareUpdate.plist

... (as a single line of code) and press the <return> key.

----

It is best that you resolve all known (MacOS X) problems, such as your printers problem, prior to performing software updates.

Prior to any software update (automatically' with 'System Preferences' 'Software Update' Utility, or by downloading and installing the update(s) manually - do a 'Disk Repair'(s) and 'Repair File Permissions' (via 'Disk Utility' - '/Applications/Utilities/' folder), prior performing any software update.
After the update(s) installation(s) (and after any possible restart [reboot]), via 'Disk Utility', do 'Repair File Permissions'.

-----

With respect to the printer problem:
You did not provide the manufacturer's name or model number of the printer.
Not provided was whether the printer's driver was installed as part of 'Panther's installation process, or if you installed it separately.
Nor was the error reported, when you attempted to print, stated.

---

A slight side track:
Create a new User Account, via 'System Preferences' 'Account' Utility.
Now, try to print something. Were you able to?
 

phishyphood2600

Registered
I tried to use the go, go to folder option and it showed that there was no file by that name, so I then went the terminal route and tried to install an update, still nothing.
Same ol' error.

The update… could not be verified or expanded correctly.
Make sure you have permission to write to /private/tmp/501/TemporaryItems/com.apple.SoftwareUpdate, then try again.

I also tried to do a combined software update to 10.3.9 and see is that works but when I try to expand the .dmg file it too tells me it is unable to expand.

I'm going to try the printer setup repair when I get home from work, not enough time this morning I will post as soon as I do though.

Help, cause this sucks.
 
Top